I today installed latest beta. I was able to solve the flash issue, and the screen tearing.

The flash issue was solved with checking a box in the system setting ( or is it kde ? )

Disable desktop effects when an application runs in full screen.

Enable V sync in amd controll center solved the tearing.

I do some to have a new problem though.

After allot of searching and installing about every 32bit mesa lib I could find, steam still complains.

The output of glxinfo proofs steam right.
I opened a topic on openSUSE forum about this, hope they can help.

Code:
name of display: :0
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
display: :0  screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: ATI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method, 
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGIS_multisample, 
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions: