Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: Radeon HDMI Linux Audio Might Be Restored Soon

  1. #21
    Join Date
    Sep 2011
    Location
    Rio de Janeiro
    Posts
    203

    Default

    Can anyone verify if 8 channel LPCM through HDMI works?

    I'm about to build a new HTPC, and now that video decoding can be offloaded to UVD, I would'nt mind decoding the sound on software and sending via HDMI to the receiver. This is also a must for surround gaming (very few, if any, receivers have analogical surround input) and sound in games are always uncompressed.

  2. #22
    Join Date
    Jul 2009
    Location
    Germany
    Posts
    540

    Default

    Quote Originally Posted by Figueiredo View Post
    Can anyone verify if 8 channel LPCM through HDMI works?

    I'm about to build a new HTPC, and now that video decoding can be offloaded to UVD, I would'nt mind decoding the sound on software and sending via HDMI to the receiver. This is also a must for surround gaming (very few, if any, receivers have analogical surround input) and sound in games are always uncompressed.
    I'm pretty sure you only get 2 channels with uncompressed LPCM through HDMI.
    It works with 6 channels encoded in DTS HD (lossless) but doesn't work with Dolby TrueHD.
    I can't test with more, because I don't have the hardware that supports 8 channels (well 8 channels DTS HD sources play fine too, but I can't check if all channels are actually played).

  3. #23
    Join Date
    Aug 2007
    Posts
    6,675

    Default

    Basically fglrx hdmi audio support is pretty bad. When you play games it often occurs that hdmi audio just stops working. As oss drivers are often too slow for those games i dont have got a direct comparison however. Therefore i got a headset for gaming, but thats already dead again after 3 months use...

  4. #24
    Join Date
    Apr 2013
    Posts
    9

    Default

    I hope they'll finally run out of Counter-Strike titles, so that they can port Portal 1/2.

  5. #25
    Join Date
    May 2013
    Posts
    1

    Default You lucky bastard

    Quote Originally Posted by droidhacker View Post
    "MAY" not= "WILL".
    A lot of it has to do with the equipment you have attached to the HDMI. For example, the Toshiba TV I have plugged into my Radeon 4200. If I change inputs on the TV, say to my satellite box, and then back to the radeon, then I get this awesome pink/purple mode (mismatched YUV vs RGB mode). It only works properly again after a full reinitialization of the connector, either by turning the TV completely off and then back on again, or by restarting the HTPC.
    I upgraded to 64 bit MINT "olivia" and now I dont even have the option of HDMI in sound setting. Only now I learnt about the GRUB thing that does not work. I find it a kind of propaganda stuff, this advice just became so virulent over the forums that the people might have started to believe it does something even without the obligate /solved/ appendix. While it only plagued the search results

  6. #26
    Join Date
    Aug 2012
    Location
    Pennsylvania, United States
    Posts
    1,938

    Default

    Quote Originally Posted by lotofag View Post
    I upgraded to 64 bit MINT "olivia" and now I dont even have the option of HDMI in sound setting. Only now I learnt about the GRUB thing that does not work. I find it a kind of propaganda stuff, this advice just became so virulent over the forums that the people might have started to believe it does something even without the obligate /solved/ appendix. While it only plagued the search results
    Wait what? What are you talking about Lotofag? if you append radeon.audio=1 to your kernel paramaters in /etc/default/grub and do "sudo update-grub" you should have working HDMI audio

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •