Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 49

Thread: AMD Releases Catalyst 13.4 For Linux

  1. #11
    Join Date
    Jan 2013
    Posts
    972

    Default

    Quote Originally Posted by uid313 View Post
    Doesn't this work with kernel 3.6, 3.7, and 3.8?
    It does.

    Doesn't this work with X.org Server 1.14 and 1.15?
    It doesn't.

  2. #12
    Join Date
    Aug 2011
    Posts
    37

    Default

    Quote Originally Posted by uid313 View Post
    * Linux kernel 2.6 or above (up to 3.5)

    What's this?
    Doesn't this work with kernel 3.6, 3.7, and 3.8?
    Read again:

    Code:
    New Features:
    Kernel 3.7 and 3.8 Support

  3. #13
    Join Date
    Aug 2009
    Posts
    150

    Default

    It is nice to get rid of the stupid watermark. At least for a while.

  4. #14
    Join Date
    Apr 2013
    Location
    Palma de Mallorca, Spain
    Posts
    2

    Default

    Quote Originally Posted by ext73 View Post
    Ok, here we go again as it was under 13.3 beta2 ... for example, the Xonotic on AMD APU E-350 [Radeon 6310] shows up to 250 fps ... but the mouse responds in "slow motion" ... You can not play ... challenge is already pressing "close game". Well the same is for example in Counter-Strike: Source, etc.. While 13.3 beta3 work brilliantly and are stable, 13.4 is for me version "alpha".
    I think I have the same problem on Ubuntu 12.04 x86_64 with Counter Strike: Condition Zero. Menus work fine but for the scroll bars (although I cannot recall whether those used to work the way they should before this update), but once in the game, the mouse lags or just doesn't work. It was working fine with Catalyst 13.2.

    On another post someone said it's to do with OpenGL. Any more information on that? Any fixes or hints?

  5. #15
    Join Date
    Apr 2013
    Location
    Palma de Mallorca, Spain
    Posts
    2

    Default

    Quote Originally Posted by d2kx View Post
    Yes I have similar problems with a Radeon HD 6870. It is a problem in the OpenGL driver, also happens with Windows.
    Updating to the latest version of Steam Client seemed to fix it for me. At least for now. Too soon to tell whether that really did the trick.

  6. #16
    Join Date
    Nov 2010
    Posts
    90

    Default

    So this update basically just adds the (ARCH) community-lead patches. I can use the legacy driver (13.1) with kernel 3.8.xx already - big deal... The problem is Xorg support - no sign of AMD actually doing any work on this - THEMSELVES??

    Folk are only going to upgrade to an Nvidia card after getting this level of after-sales support!! I can run my 8800 GTX - ancient history compared to the Radeon 4xxx(M) series - with the latest display driver, Xorg and kernel versions - when using the proprietary Nvidia driver.

  7. #17
    Join Date
    Apr 2007
    Location
    Arctic circle, Finland
    Posts
    260

    Default

    Hmm just wondered is there same opengl4.3 features added as windows drivers :
    Feature Highlights of AMD Catalyst™ 13.4
    *snip useless d3d part information*
    Delivers support for the following OpenGL 4.3 features:
    GL_ARB_compute_shader
    GL_ARB_multi_draw_indirect
    GL_ARB_shader_storage_buffer_object
    GL_ARB_arrays_of_arrays
    GL_ARB_clear_buffer_object
    GL_ARB_ES3_compatibility
    GL_ARB_explicit_uniform_location
    GL_ARB_fragment_layer_viewport
    GL_ARB_invalidate_subdata
    GL_ARB_program_interface_query
    GL_ARB_shader_image_size
    GL_ARB_stencil_texturing
    GL_ARB_texture_buffer_range
    GL_ARB_texture_query_levels
    GL_ARB_texture_storage_multisample
    Does anyone installed them, please show glxinfo.

  8. #18
    Join Date
    Nov 2007
    Posts
    1,353

    Default

    the catalyst driver for linux and windows is the same code. so whatever features are changed applies to both OS's

  9. #19
    Join Date
    Nov 2008
    Location
    Old Europe
    Posts
    885

    Default

    Quote Originally Posted by bobwya View Post
    So this update basically just adds the (ARCH) community-lead patches. I can use the legacy driver (13.1) with kernel 3.8.xx already - big deal... The problem is Xorg support - no sign of AMD actually doing any work on this - THEMSELVES??

    Folk are only going to upgrade to an Nvidia card after getting this level of after-sales support!! I can run my 8800 GTX - ancient history compared to the Radeon 4xxx(M) series - with the latest display driver, Xorg and kernel versions - when using the proprietary Nvidia driver.
    There was no chance xserver 1.14 support will come with this official release.
    Simply because the public beta drivers didn't feature it.
    *Maybe*, since we have new an official release, we can hope that the next beta releases have xserver 1.14 support.

    Now waiting for 13.4 hitting Arch...

  10. #20
    Join Date
    Apr 2011
    Location
    Atlanta, GA, USA
    Posts
    11

    Angry

    Quote Originally Posted by Vim_User View Post
    Quote Originally Posted by uid313,327503
    Doesn't this work with X.org Server 1.14 and 1.15?
    It doesn't.
    Argh... Why do they make me hate supporting the development of their open driver by not supporting current X.org releases with their closed driver? My next gaming GPU will be back to Nvidia unless something changes.

    =-Jameson

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •