Quote Originally Posted by Sonadow View Post
No, by 'chrome' i refer to the window decorator / window bar (which is also called the chrome in some circles) that contains the 'X', minimize and maximize buttons, which you mentioned was also missing in many application windows.
Ah, I see. Well, Weston is there and so (I expect) that functionality to be there to (is it called the chrome? really? confusing.. anyway, thanks for clearing that up). But I suppose that not all the toolkits are fully ported (or contain bugs).

Quote Originally Posted by Sonadow View Post
If i wanted Chrome / Chromium I would roll my own build using upstream sources and not download a binary version, just because I can (even though it takes 9 hours to build the browser on my ancient processor). Which i doubt is even possible on Rebecca Black at this point of time without access to the whole chunk of development libraries Chromium demands for the build process.
It's a stock modified Ubuntu install disk. You could do a install build-dep of the chromium package and roll your own source. Should not be much more work than a 'traditional' installed Ubuntu.

Quote Originally Posted by nerdopolis View Post
To get KDE apps to work, you have to run them from the xterm xwayland app, because I have it set to use the default variables. The wayland terminal has the /opt in it's library paths. ...KDE apps crash because I have KDE frameworks in /opt (or you can just run
xwaylandapp konsole
for example to get an x program started with the default variables)
xterm wayland app? I did find 'an' xterm in the launcher which did not work. The Wayland terminal worked good. What surprises me, is that konsole works really good. It has the close, minimize and maximize buttons. And scrolling with my mousewheel works. Furthermore, it does not crash when saving to clipboard (which Firefox did).

Quote Originally Posted by nerdopolis View Post
As for the screenshot, the Super+s, should save the screenshot in your /home/username . The built in screenshooter tool that comes with weston does not have a GUI,
I tried Windows+S, Alt+S, Ctrl+S (who knows?) and a button which indicates a menu and an arrow selecting one if it's entries ... + S . None worked, I checked /home/beccaholic and /root. No dice. I also switched tty's to see if Wayland complained, which was not the case (I don't see a .xsession-errors? is there an equivalent?). Also, TTY switching made the Wayland session crash for the first time for me.

Having said that, it recovers pretty fast though.

Quote Originally Posted by nerdopolis View Post
and because of security, only special apps called directly by weston itself, like the weston screenshooter have access to capture the entire display, so that's why ksnapshot won't work.
That's 'interesting'. So, Xwayland will not be able to handle screenshoting/recording apps, I guess?

Thanks for your effort!