Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: A Flurry Of OSS ATI Driver Improvements

  1. #11
    Join Date
    Oct 2007
    Location
    Roanoke, VA
    Posts
    228

    Default

    Quote Originally Posted by agd5f View Post
    That procedure applies to any driver in freedesktop git.
    The folks over on Ubuntuforums.org are having some problems. They're also not very positive on the driver changes for some reason.

    Can you help this guy: http://ubuntuforums.org/showthread.p...20#post4422720

    And also take a look at the full thread and see what you think? I'd like to see the new driver changes included in Hardy Heron when it launches but it seems as though some of the Ubuntu developers are dead-set against it.

  2. #12
    Join Date
    May 2007
    Posts
    352

    Default

    I don't have an account there, and see no obvious option to create one. However, it's pretty clear that Formica45 needs to install the autoconf package (and probably various other development packages).

    Adam

  3. #13
    Join Date
    Oct 2007
    Posts
    22

    Default Tried it out...

    And I'm having issues (I know, what do I expect when checking out from development tree, but then again, I've been having to cope with the monthly fglrx driver, which hasn't been that much better

    Anyway, background is Mobility FireGL V5200 on a Thinkpad T60p, running Gutsy with only the driver checked out from git against Gutsy's default X server:
    -Gradients look *terrible* on my built in panel Like undithered 16-bit color, despite being in 24 bit depth (verified in xdpyinfo). I wonder about today's "disable dithering on DFPs" checkin.
    -Attempted to run mplayer on a DVD iso with xv. It locked the system up hard.


    And the good news:
    -I can suspend. This has not been possible ever with the fglrx drivers on my laptop with Gutsy.

    And the question on my mind:
    -When/where will I get my GL acceleration?
    Last edited by makoto42; 02-28-2008 at 08:54 PM.

  4. #14
    Join Date
    Aug 2006
    Posts
    90

    Default

    I'm having a lot of success with the recent driver on my Radeon 9500. EXA acceleration finally really works (due to Xrender I believe), and compiz finally feels just as fast as Kwin.

    A couple of minor things:
    1) I get really minor purple dot artifacts when I use compiz. I tried reporting this on IRC, but didn't have much luck. I know devs read the forum too. See here: http://sknauert.web.wesleyan.edu/artifacts.png (look in the corners and in the clear part of the menu bars) Yes, I know its minor, but it would be nice to fix.

    2) Is there a way to tell X to use textured video on an 9500 or 9700 Pro? My Xv still uses overlay and textured video would look nicer with compiz, not to mention I have a feeling it might actually be faster.
    Last edited by Tillin9; 02-29-2008 at 01:19 AM.

  5. #15
    Join Date
    Dec 2007
    Posts
    2,395

    Default

    Quote Originally Posted by Tillin9 View Post
    Is there a way to tell X to use textured video on an 9500 or 9700 Pro? My Xv still uses overlay and textured video would look nicer with compiz, not to mention I have a feeling it might actually be faster.
    Both the overlay and the textured adapters are supported. xvinfo will show you the adapter information. The overlay is the first port and the next 16 are textured ports. To use a textured adapter, specify the port you want to use. mplayer for example uses the port=<number> option to specify the port.

  6. #16
    Join Date
    Jan 2008
    Posts
    156

    Default

    A quick feedback (I'm esting on a Xpress 200M 5955):
    -Not much change compared to 6.8.0 : good 2D quality, XV works fine and looks very good to me, fonts look very good, glxgears seems somewhat accelerated (though far from other scores with better video cards and still lower then fglrx 1070 compared to about 1600-1700 with fglrx).
    - Compositing in KWin4 kind of works with XRender. Compositing with OpenGL freezes X11 **BUT** this time, I did have the begining of a composited window appear, with some shadow! :-) Before that, it was just a black screen.

    So there's definitely an improvement here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •