Results 1 to 2 of 2

Thread: Open source Ati working with compiz but strange problems..

  1. #1
    Join Date
    Feb 2008
    Posts
    11

    Exclamation Open source Ati working with compiz but strange problems..

    Hi everyone
    i finally got compiz working with my ati radeon 9800 card by using the open source driver, every experiment with fglrx was a failure moreover most of the time they lock me out of X even with metacity or just give no DRI.

    With the open source drivers and no compositor they do work great, i have around 3600fps with my card, but if i turn on compiz the fps drop to 1400 with a strange behaviour:

    glxgears works full speed for a second, then stops, then again full speed, then stops, then again full speed.
    and so on..
    Actually it is working in an on-off way, and i don't know how to fix it..
    If someone has more experience to give out some hints i'd gladly try
    Here is my xorg.conf
    Code:
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
    	
    	# Uncomment if you have a wacom tablet
    	#	InputDevice     "stylus"	"SendCoreEvents"
    	#	InputDevice     "cursor"	"SendCoreEvents"
    	#	InputDevice     "eraser"	"SendCoreEvents"
    	Identifier	"Default Layout"
      screen 0 "aticonfig-Screen[0]" 0 0
    	Inputdevice	"Generic Keyboard"
    	Inputdevice	"Configured Mouse"
    #	Option 		"AIGLX"		"true"
    	
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
            Load		"glx"
    	Load		"dri"
    EndSection
    
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"it"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"	"/dev/input/mice"
    	Option		"Protocol"	"ImPS/2"
    	Option		"ZAxisMapping"	"4 5"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "InputDevice"
    	Identifier	"stylus"
    	Driver		"wacom"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"stylus"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Identifier	"eraser"
    	Driver		"wacom"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"eraser"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Identifier	"cursor"
    	Driver		"wacom"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"cursor"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "Monitor"
    	Identifier	"aticonfig-Monitor[0]"
    	Option		"VendorName"	"ATI Proprietary Driver"
    	Option		"ModelName"	"Generic Autodetecting Monitor"
    	Option		"DPMS"	"true"
    EndSection
    
    Section "Device"
    	Identifier	"aticonfig-Device[0]"
    	Driver		"radeon"
    	Option		"AccelMethod"	"XAA"
    	Option		"XAANoOffscreenPixmaps"	"true"
    	Option		"RenderAccel"	"true"
    	Option		"EnablePageFlip"	"true"
    	Option		"backingstore"	"true"
    	Option 		"SubPixelOrder"	"none"
    	Option		"ColorTiling"	"on"
    	Option		"mtrr"		"off"
    	Option		"AGPMode"	"8"
    	Option		"GARTSize"	"64"
    	Option		"VideoOverlay"	"on"
    	Option		"OpenGLOverlay"	"off"
    	BusID		"PCI:1:0:0"
    #	Option		"TripleBuffer" "true"
    	Option		"AddARGBLXVisuals" "true"
    EndSection
    
    Section "Screen"
    	Identifier	"aticonfig-Screen[0]"
    	Device		"aticonfig-Device[0]"
    	Monitor		"aticonfig-Monitor[0]"
    	Defaultdepth	24
    	SubSection "Display"
    		Viewport	0	0
    		Depth	24
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Mode	0666
    EndSection
    
    Section "Extensions"
    	Option "Composite" "Enable"
    EndSection

  2. #2
    Join Date
    Jun 2007
    Posts
    406

    Default

    Quote Originally Posted by assasukasse View Post
    Hi everyone
    i finally got compiz working with my ati radeon 9800 card by using the open source driver, every experiment with fglrx was a failure moreover most of the time they lock me out of X even with metacity or just give no DRI.

    With the open source drivers and no compositor they do work great, i have around 3600fps with my card, but if i turn on compiz the fps drop to 1400 with a strange behaviour:

    glxgears works full speed for a second, then stops, then again full speed, then stops, then again full speed.
    and so on..
    Actually it is working in an on-off way, and i don't know how to fix it..
    If someone has more experience to give out some hints i'd gladly try
    Here is my xorg.conf
    Code:
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
    	
    	# Uncomment if you have a wacom tablet
    	#	InputDevice     "stylus"	"SendCoreEvents"
    	#	InputDevice     "cursor"	"SendCoreEvents"
    	#	InputDevice     "eraser"	"SendCoreEvents"
    	Identifier	"Default Layout"
      screen 0 "aticonfig-Screen[0]" 0 0
    	Inputdevice	"Generic Keyboard"
    	Inputdevice	"Configured Mouse"
    #	Option 		"AIGLX"		"true"
    	
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
            Load		"glx"
    	Load		"dri"
    EndSection
    
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"it"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"	"/dev/input/mice"
    	Option		"Protocol"	"ImPS/2"
    	Option		"ZAxisMapping"	"4 5"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "InputDevice"
    	Identifier	"stylus"
    	Driver		"wacom"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"stylus"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Identifier	"eraser"
    	Driver		"wacom"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"eraser"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Identifier	"cursor"
    	Driver		"wacom"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"cursor"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "Monitor"
    	Identifier	"aticonfig-Monitor[0]"
    	Option		"VendorName"	"ATI Proprietary Driver"
    	Option		"ModelName"	"Generic Autodetecting Monitor"
    	Option		"DPMS"	"true"
    EndSection
    
    Section "Device"
    	Identifier	"aticonfig-Device[0]"
    	Driver		"radeon"
    	Option		"AccelMethod"	"XAA"
    	Option		"XAANoOffscreenPixmaps"	"true"
    	Option		"RenderAccel"	"true"
    	Option		"EnablePageFlip"	"true"
    	Option		"backingstore"	"true"
    	Option 		"SubPixelOrder"	"none"
    	Option		"ColorTiling"	"on"
    	Option		"mtrr"		"off"
    	Option		"AGPMode"	"8"
    	Option		"GARTSize"	"64"
    	Option		"VideoOverlay"	"on"
    	Option		"OpenGLOverlay"	"off"
    	BusID		"PCI:1:0:0"
    #	Option		"TripleBuffer" "true"
    	Option		"AddARGBLXVisuals" "true"
    EndSection
    
    Section "Screen"
    	Identifier	"aticonfig-Screen[0]"
    	Device		"aticonfig-Device[0]"
    	Monitor		"aticonfig-Monitor[0]"
    	Defaultdepth	24
    	SubSection "Display"
    		Viewport	0	0
    		Depth	24
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Mode	0666
    EndSection
    
    Section "Extensions"
    	Option "Composite" "Enable"
    EndSection
    this should go in the other forum since it's related to the opensource driver.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •