Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Benchmarking The Intel P-State, CPUfreq Changes

  1. #1
    Join Date
    Jan 2007
    Posts
    15,413

    Default Benchmarking The Intel P-State, CPUfreq Changes

    Phoronix: Benchmarking The Intel P-State, CPUfreq Changes

    On Friday there was the controversial news about the Linux "ondemand" cpufreq governor no longer being fit for best performance and power-savings on modern processors. Fortunately, for better handling the CPU frequency stage changes on modern Intel CPUs, Intel recently introduced the new P-State kernel driver...

    http://www.phoronix.com/vr.php?view=MTM3NTI

  2. #2
    Join Date
    Sep 2012
    Posts
    296

    Default

    Could it be that only some specific processors are affected by the performance/ondemand bug ?

  3. #3
    Join Date
    Sep 2008
    Location
    Vilnius, Lithuania
    Posts
    2,636

    Default

    Interesting, so using P-state powersave mode shouldn't cause performance issues in mesa, while it does if using cpufreq. Can't wait to see the power usage benchmarks.

    Quote Originally Posted by wargames View Post
    Could it be that only some specific processors are affected by the performance/ondemand bug ?
    Bug? What bug?

  4. #4
    Join Date
    Dec 2012
    Posts
    41

    Default Perfomance not the issue

    What you should really measure is %time idle and power consumption. In switching from ondemand to performance, I saw %idle go from ~50% to ~95% (C6-IVB).

    It honestly doesn't make much of a difference when idle (~94% idle to ~99%), but when only one thread is under load, it's a nice improvement.

    Maybe break out your killawatt?

  5. #5
    Join Date
    Jun 2012
    Posts
    11

    Default

    I think P state is broken, or devs in Arch Linux broke something. In Powersave cpu is always at the lowest frequency and it's terrible when working. Performance is buggy and after suspend cpu can be constantly at highest frequency… Also (at least in Arch) you have to set manually Performance after every reboot, because it's not remembered as with cpufreq governors.

    I've switched off it and now I'm waiting for fixes…

  6. #6
    Join Date
    May 2012
    Posts
    912

    Default

    I can usually guess the result of the benchmark before reading the article. If anything big happened the title would reflect it, if nothing much changed it just says like "benchmarking X with Y".

  7. #7
    Join Date
    Sep 2008
    Location
    Vilnius, Lithuania
    Posts
    2,636

    Default

    Quote Originally Posted by Druedain View Post
    I think P state is broken, or devs in Arch Linux broke something. In Powersave cpu is always at the lowest frequency and it's terrible when working. Performance is buggy and after suspend cpu can be constantly at highest frequency… Also (at least in Arch) you have to set manually Performance after every reboot, because it's not remembered as with cpufreq governors.

    I've switched off it and now I'm waiting for fixes…
    Uhm, that's exactly how ACPI cpufreq is supposed to work...

  8. #8
    Join Date
    Feb 2011
    Location
    Ukraine
    Posts
    146

    Default

    Problem with _RADEON_ driver and kernel 3.8+


  9. #9
    Join Date
    Aug 2012
    Location
    Pennsylvania, United States
    Posts
    1,920

    Default

    Quote Originally Posted by Druedain View Post
    I think P state is broken, or devs in Arch Linux broke something. In Powersave cpu is always at the lowest frequency and it's terrible when working. Performance is buggy and after suspend cpu can be constantly at highest frequency… Also (at least in Arch) you have to set manually Performance after every reboot, because it's not remembered as with cpufreq governors.

    I've switched off it and now I'm waiting for fixes…

    I can't comment on the suspend isues but the issue of setting it at every boot seems a bit odd. Are you running cpupowerd? If you performance as the default governor in /etc/default/cpupower and enable the cpupowerd service then it should auto-set to performance. Also I doubt the Arch devs broke anything, they dont modify kernels, that being said, p-states COULD be broken in some way.


    Back onto the article though... I'm running 3.10rc1 on Arch using the P-State governor and quite honestly...it seems to be working. My power usage hasn't gone up, and maybe its thermald or maybe its both P-state and thermald working together but my thermal temps have never been lower and in this laptop the ONLY thing generating heat is pretty much the Intel die since its a Sandy Bridge laptop with no discrete GPU.

  10. #10
    Join Date
    Sep 2008
    Location
    Vilnius, Lithuania
    Posts
    2,636

    Default

    Quote Originally Posted by Ericg View Post
    Are you running cpupowerd?
    Or just make a systemd unit file that sets the kernel variables to needed values on each boot, if a static setting is desired.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •