Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Garry's Mod Running On Linux

  1. #11
    Join Date
    Mar 2013
    Location
    California
    Posts
    124

    Default

    Quote Originally Posted by IanS View Post
    I didn't; Garry did. I had to restart my machine and when I restarted my Steam client an update for GMod ran and I tried to launch it again and I got through to the main menu for the game.



    If you own it and can't install/launch it, then it is probably because you didn't opt into the development beta, there was an announcement a few days back by Garry that using the secret word from the game will give you access to the new SteamPipe-based development beta. http://linuxgamecast.com/2013/05/gar...lient-support/
    I was able to select development beta without any code.

  2. #12
    Join Date
    Jan 2013
    Posts
    209

    Default

    Quote Originally Posted by philip550c View Post
    I was able to select development beta without any code.
    He must of made it public within the last day or so then. When I installed I needed the code.


    Just got done playing it for a bit, seems to be working quite well now.

  3. #13
    Join Date
    Jun 2010
    Location
    ฿ 16LDJ6Hrd1oN3nCoFL7BypHSEYL84ca1JR
    Posts
    1,052

    Default

    Seems one segfault is as good as tracked down
    Code:
    #0  0xf5aa086a in _mesa_BindFramebuffer () from /usr/lib32/libdricore9.2.0.so.1
    #1  0xf77d4871 in ?? () from /home/user/steamlibrary/common/GarrysMod/bin/libtogl.so
    ...
    In mesa 9.2 it crashes when togl throws around a GL_ZERO somewhere while on 9.1 it doesn't and according to a commenter on the bugreport this is out of OpenGL spec so it would be a bug in some library not from garry but from valve:
    https://github.com/Facepunch/garrysm...mment-19052329
    Last edited by ChrisXY; 06-06-2013 at 03:30 PM.

  4. #14
    Join Date
    Nov 2007
    Posts
    77

    Default

    Quote Originally Posted by ChrisXY View Post
    Seems one segfault is as good as tracked down
    Code:
    #0  0xf5aa086a in _mesa_BindFramebuffer () from /usr/lib32/libdricore9.2.0.so.1
    #1  0xf77d4871 in ?? () from /home/user/steamlibrary/common/GarrysMod/bin/libtogl.so
    ...
    In mesa 9.2 it crashes when togl throws around a GL_ZERO somewhere while on 9.1 it doesn't and according to a commenter on the bugreport this is out of OpenGL spec so it would be a bug in some library not from garry but from valve:
    https://github.com/Facepunch/garrysm...mment-19052329
    Yup togl isn't to spec so latest mesa or 9.2 crashes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •