Page 28 of 28 FirstFirst ... 18262728
Results 271 to 279 of 279

Thread: AMD Has Massive Radeon Patch Set - Power Management!

  1. #271
    Join Date
    Jan 2010


    Quote Originally Posted by Xipeos View Post
    Not sure what you meant. Current code already sets my (desktop) card to the "cool and quiet" power state, so clock gating wouldn't change much. I need/want the driver to switch my card to the higher-performing power state(s) in the "3d_perf" class (with max clocks and voltage) when required.
    Clock gating disables the clock signals to unused hardware blocks completely if they are not in use. This can make a big difference in terms of power consumption, even compared to a low clock. The old PM code wasn't capable of clock gating at all.

  2. #272
    Join Date
    Jun 2013


    Quote Originally Posted by droste View Post
    For me it's the other way around: It's always at full speed.
    The only change I noticed is when running UVD, but this results in a hard (or soft? changing VT doesn't work but SysRq+REISUB reboots the machine) lock after a few seconds.

    This is with 7982128c3d447df27db963af67bc6b8dc7efb1de from the drm-next-3.11 branch but the commits after that doesn't seem to change any behavior for evergreen cards.
    This laptop I'm using is an Evergreen card (HD5400 CEDAR if this counts as an Evergreen) and everything works just fine...
    You have the appropiate firmware for your card, yes?

  3. #273
    Join Date
    Jul 2009


    Yes everything is set up correctly. Actually I'm the one who explained it to you, how to set this up, so if it is working for you, it should be working for me :-D
    DPM and UVD are initialized without errors (dmesg).
    UVD is working but stopping UVD playbacks and switching back to a non-UVD power state is locking up the PC sometimes.
    DPM does nothing until UVD is used. There it correctly switches power states and power level until the playback ends. After that the power level goes back to power level 2 and stays there.


  4. #274
    Join Date
    Sep 2011


    Quote Originally Posted by d2kx View Post
    With latest code I still get soft lockup during boot and UVD not working (E-350 & HD 6870). Also on my HD 6870, bad 3D performance because it doesn't increase speeds in games.
    On my E-350 I also get a lock-up but it works if I remove the SUMO_uvd firmware file.

  5. #275
    Join Date
    Sep 2012


    glad i'm not the only one with e350 problems with DPM and UVD enabled.

    fritsch one of the XBMC coders posted a patch to get uvd and dpm working together.

    diff --git a/drivers/gpu/drm/radeon/sumo_dpm.c b/drivers/gpu/drm/radeon/sumo_dpm.c
    index dbad293..a71cbb6 100644
    --- a/drivers/gpu/drm/radeon/sumo_dpm.c
    +++ b/drivers/gpu/drm/radeon/sumo_dpm.c
    @@ -1727,7 +1727,8 @@ int sumo_dpm_init(struct radeon_device *rdev)
     	pi->enable_sclk_ds = true;
     	pi->enable_dynamic_m3_arbiter = false;
     	pi->enable_dynamic_patch_ps = true;
    -	pi->enable_gfx_power_gating = true;
    +        /* workaround to make UVD + DPM work together */
    +	pi->enable_gfx_power_gating = false;
     	pi->enable_gfx_clock_gating = true;
     	pi->enable_mg_clock_gating = true;
     	pi->enable_auto_thermal_throttling = true;
    Last edited by deadite66; 07-06-2013 at 03:45 AM.

  6. #276
    Join Date
    Apr 2008


    I have tons of this error messages in dmesg, but everything seems fine

    HD7640G + HD7670M(closed through vgaswitcheroo), mesa and xf86-video-ati 20130706, llvm 3.4. kernel agd5f's drm-next-3.11 branch 20130705.
    [ 3561.423301] radeon 0000:00:01.0: GPU fault detected: 147 0x012d1502
    [ 3561.423307] radeon 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x00000000
    [ 3561.423312] radeon 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x00000000
    [ 3561.423318] radeon 0000:00:01.0: GPU fault detected: 147 0x012d2502
    [ 3561.423324] radeon 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x00000000
    [ 3561.423330] radeon 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x00000000
    And when use mplayer and vdpauinfo, i got this message, but also seems harmless
    Inconsistency detected by dl-close.c: 765: _dl_close: Assertion `map->l_init_called' failed!
    Last edited by jarryson; 07-06-2013 at 07:26 AM.

  7. #277
    Join Date
    Jan 2007


    Quote Originally Posted by Massa View Post
    On my E-350 I also get a lock-up but it works if I remove the SUMO_uvd firmware file.
    Yeah, this works, thanks.

  8. #278
    Join Date
    May 2011

    Default black screen on 6740

    while an early try with drm-next-3.11-wip worked (but was slow-ish),
    latest drm-next-3.11 @f4dec318 gives a flash of garbled output
    then black screen, as soon as drm loads. Kernel crash.
    Nothing about the crash is logged on disk after reboot.
    PC is imac12,2, efi-booted.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts