Hi All,

I've been playing with linux for a while but don't really understand the nuts and bolts, so pleas make allowances for ignorance!

I have FC6 installed on my AMD64 X2 box. Gotta say, on my old PC (32 bit single processor) Linux worked like a charm most of the time. Since I've upgraded I've had a lot more problems. Linux just doesn't seem to be as stable on the new architecture. But that's another story.

When I run update system under kyum (and if I do it in a terminal, i.e. "yum update") it gives me an incompatibility error with mkinitrd.

file /sbin/mkinitrd from install of mkinitrd- conflicts with file from package mkinitrd-5.1.19-1

I had a shot at deinstalling mkinitrd, but it seems to be pretty important, there seemed to be a lot of kernel modules that it wanted to uninstall as well, and it looked like my PC would not boot without it. So I chickened out.

As I mentioned lots of stuff doesn't work properly (I can't see YouTube videos in Firefox or Konqueror, KsCD doesn't work, Cups refuses to print. They all used to work until I tried to install Aptana, which seems to have killed X server (managed to fix that) and a few other things as well), so I figured if I update everything maybe it will all end up back in sync again, and everything would work again.

All advice gratefully received.