Results 1 to 4 of 4

Thread: Haswell Perf Doesn't Change Much On Linux 3.11

  1. #1
    Join Date
    Jan 2007
    Posts
    14,788

    Default Haswell Perf Doesn't Change Much On Linux 3.11

    Phoronix: Haswell Perf Doesn't Change Much On Linux 3.11

    The Intel Haswell HD Graphics 4600 performance for OpenGL doesn't change much if trying out the experimental Linux 3.11 kernel...

    http://www.phoronix.com/vr.php?view=MTQxNTY

  2. #2
    Join Date
    Jul 2013
    Posts
    204

    Default

    It's still only -rc1, so perhaps more performance enhancements will come down the road.

    I don't have Intel graphics anymore, but it's nice to see them actually getting into the playing field.

  3. #3
    Join Date
    Apr 2009
    Posts
    548

    Default

    I did my own testing with rc1 a couple days ago, and had similar results, so i went back to 3.10, for my Haswell system.

    What I don't get is the overclocking situation. I am running all the latest stuff, set the bios to use the GPU at a 1350 speed (instead of the default 1200), and after booting up I enable it via /sys

    Code:
    echo 1350 > /sys/class/drm/card0/gt_max_freq_mhz
    However, the graphics tests run actually much _slower_ , not faster. I am pretty much stumped ... I've been asking here, but I don't think anybody else is trying this. Kernel 3.11rc1 has the same issue. My motherboard BIOS is up to date.

    Cheers!
    Last edited by mendieta; 07-20-2013 at 01:59 PM.

  4. #4
    Join Date
    Apr 2009
    Posts
    548

    Default

    There is clearly some funky stuff going on with overclocking. Because glgears does improve about 10% with a 10% overclocking, but much more advanced tests like glmark2 don't, with rc2 and current graphics stack from xorg-edgers. Sigh.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •