Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Legacy Radeon Gallium3D Performance Drops On Mesa 9.2

  1. #1
    Join Date
    Jan 2007
    Posts
    14,623

    Default Legacy Radeon Gallium3D Performance Drops On Mesa 9.2

    Phoronix: Legacy Radeon Gallium3D Performance Drops On Mesa 9.2

    It's been a while since delivering any benchmarks from legacy ATI/AMD Radeon hardware like the X1000 (R500) series on Linux. However, with the release of Mesa 9.2 from late August, here are new benchmarks of the Radeon X1000 series GPUs on the open-source Radeon "R300g" Gallium3D graphics driver.

    http://www.phoronix.com/vr.php?view=19106

  2. #2

    Default Control Panel

    We as users need an easy way to turn on/off the various forms of anti-aliasing, for those who may not want or need to use it, or for older cards such as this which struggle to use it anyways.

  3. #3
    Join Date
    Jul 2009
    Posts
    250

    Default

    same applies to Intel GM945 Graphics. its now OpenGL 2.1 capable, but slow as hell. everything with some sort of blurr is a pain in the *** alt+tab, i.e. power button or the usual way to turn off the laptop.

    slightly off topic but: would it make sense for newer CPUs for instance (or GM945 users) to compile, kernel and mesa (and with it hopefully the llvmpipe) via apt-build to provide all the power your CPU can offer? Why apt build? Simply to provide a simple and automated way to install self-compiled binaries?
    Last edited by jakubo; 09-13-2013 at 10:13 AM.

  4. #4
    Join Date
    Sep 2012
    Posts
    22

    Question regression?

    Can be used PTS to track commit causing this? As user of r300g, I'm interested in this.

  5. #5
    Join Date
    Jan 2012
    Posts
    151

    Default

    Quote Originally Posted by halfmanhalfamazing View Post
    We as users need an easy way to turn on/off the various forms of anti-aliasing, for those who may not want or need to use it, or for older cards such as this which struggle to use it anyways.
    When you say easy, do you mean via a GUI? Could simply set GALLIUM_MSAA. See MLAA for how to set MLAA, which uses driconf. I don't think you can set MSAA levels via driconf.

    Note to Michael: when running pre/post mesa 9.2, set GALLIUM_MSAA environment variable to 0, please.

  6. #6
    Join Date
    Jan 2009
    Posts
    621

    Default

    Quote Originally Posted by FourDMusic View Post
    Note to Michael: when running pre/post mesa 9.2, set GALLIUM_MSAA environment variable to 0, please.
    It won't help. GALLIUM_MSAA can only be used to enable MSAA if MSAA is disabled. If an app enables MSAA, GALLIUM_MSAA has no effect.

  7. #7
    Join Date
    Jan 2012
    Posts
    151

    Default

    Quote Originally Posted by marek View Post
    It won't help. GALLIUM_MSAA can only be used to enable MSAA if MSAA is disabled. If an app enables MSAA, GALLIUM_MSAA has no effect.
    thanks for the clarification!

  8. #8
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,061

    Default

    Clearly we need a disable toggle then, preferably via driconf

  9. #9
    Join Date
    Jan 2009
    Posts
    621

    Default

    Forcing MSAA off might break some apps, because MSAA adds a couple of neat features like alpha-to-coverage and sample mask, and disabling MSAA would also disable the features.

    In other words, if you want to disable MSAA, fix the phoronix test profiles.

  10. #10
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,061

    Default

    That only works if the app offers the choice to disable it. If it only offers autodetection...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •