Results 1 to 4 of 4

Thread: pts/crafty, pts/espeak, pts/apache missing dependencies

  1. #1
    Join Date
    Aug 2013
    Posts
    6

    Default pts/crafty, pts/espeak, pts/apache missing dependencies

    Hey,

    found out few tests are missing deps (tested on Ubuntu):

    pts/crafty - missing unzip
    pts/espeak - missing unzip
    pts/apache - missing libpcre3-dev

    ---
    //_ Lazar Obradovic

  2. #2

    Default

    Quote Originally Posted by lgnd33 View Post
    Hey,

    found out few tests are missing deps (tested on Ubuntu):

    pts/crafty - missing unzip
    pts/espeak - missing unzip
    pts/apache - missing libpcre3-dev

    ---
    //_ Lazar Obradovic
    PTS should be installing all of these necessary dependencies automatically. Are you blocking that or not seeing the prompts?

  3. #3
    Join Date
    Aug 2013
    Posts
    6

    Default

    Nope, nothing really. I never get the prompts nor these ever get installed.

    I'm actually writing a tutorial for some of my colleagues and steps are:
    1. Install default Ubuntu 12.04 LTS (just add OpenSSH support)
    2.Update and upgrade
    Code:
      $ sudo apt-get update
      $ sudo apt-get dist-upgrade
    3. Instal PTS (this will install 4.6, but still)
    Code:
      $ sudo apt-get install phoronix-test-suite
    4. Install test suite:
    Code:
      $ phoronix-test-suite install universe-cli
    This one breaks with all the stuff I reported earlier, including this unzip/libpcre3-dev dependency.
    Main issue was that sudo aptitude mishandling in install-ubuntu-packages.sh (saw that in dev thread? not sure it's the right place, though)

    ---
    //_ Lazar Obradovic

  4. #4

    Default

    Quote Originally Posted by lgnd33 View Post
    Nope, nothing really. I never get the prompts nor these ever get installed.

    I'm actually writing a tutorial for some of my colleagues and steps are:
    1. Install default Ubuntu 12.04 LTS (just add OpenSSH support)
    2.Update and upgrade
    Code:
      $ sudo apt-get update
      $ sudo apt-get dist-upgrade
    3. Instal PTS (this will install 4.6, but still)
    Code:
      $ sudo apt-get install phoronix-test-suite
    4. Install test suite:
    Code:
      $ phoronix-test-suite install universe-cli
    This one breaks with all the stuff I reported earlier, including this unzip/libpcre3-dev dependency.
    Main issue was that sudo aptitude mishandling in install-ubuntu-packages.sh (saw that in dev thread? not sure it's the right place, though)

    ---
    //_ Lazar Obradovic
    Can you try adding a simple debug statement (like a simple print) to pts-core/external-dependencies/scripts/install-ubuntu-packages.sh to see if at least this file is being called?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •