Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: How to enable opengl 3.3 on r9 270?

  1. #1
    Join Date
    Feb 2013
    Posts
    253

    Default How to enable opengl 3.3 on r9 270?

    Question in the title. Using Ubuntu 14.04 with 3.14 kernel and oibaf PPA(mesa 10.2)

    Reading around I should have openGL 3.3, but it's only 3.0? I can't run a lot of benchmarks/games that require later GL versions.

  2. #2
    Join Date
    Jul 2009
    Location
    Germany
    Posts
    438

    Default

    OpenGL 3.1 and higher are only available with the core profile. If you run "glxinfo | grep core" it should give you the highest version available with a core profile.

  3. #3
    Join Date
    Feb 2013
    Posts
    253

    Default

    Quote Originally Posted by droste View Post
    OpenGL 3.1 and higher are only available with the core profile. If you run "glxinfo | grep core" it should give you the highest version available with a core profile.
    OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.2.0-devel (git-857f3a6 trusty-oibaf-ppa)

    Is this normal? I can't run unigine heaven It works just fine with fglrx

  4. #4
    Join Date
    Jul 2009
    Location
    Germany
    Posts
    438

    Default

    Hm maybe kernel too old? AFAIK radeonsi should be at OGL 3.3.

    you could try to run it with MESA_GL_VERSION_OVERRIDE=3.2 and MESA_GLSL_VERSION_OVERRIDE=150 set.

    Code:
    MESA_GL_VERSION_OVERRIDE=3.2 MESA_GLSL_VERSION_OVERRIDE=150 ./heaven

  5. #5
    Join Date
    Feb 2013
    Posts
    253

    Default

    Quote Originally Posted by droste View Post
    Hm maybe kernel too old? AFAIK radeonsi should be at OGL 3.3.

    you could try to run it with MESA_GL_VERSION_OVERRIDE=3.2 and MESA_GLSL_VERSION_OVERRIDE=150 set.

    Code:
    MESA_GL_VERSION_OVERRIDE=3.2 MESA_GLSL_VERSION_OVERRIDE=150 ./heaven
    Tried with both kernel 3.14 and 3.13, it's the same on both. HDMI audio doesn't work on 3.14 so I'm back on 3.13...

    Trying that just outputs a black screen

    Code:
    GLFfp::create_shader(): can't create shader
    0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
    GLFfp::create_shader(): can't create shader
    0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
    GLFfp::create_shader(): can't create shader
    0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
    GLFfp::create_shader(): can't create shader
    0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
    GLFfp::create_shader(): can't create shader
    0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
    GLFfp::create_shader(): can't create shader
    0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
    GLFfp::create_shader(): can't create shader
    0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
    GLFfp::create_shader(): can't create shader
    0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
    GLFfp::create_shader(): can't create shader
    0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, and 1.00 ES
    OpenGL error: invalid value

  6. #6
    Join Date
    Feb 2013
    Posts
    253

    Default

    Hum, not sure what I did but the override seems to be working now. I wonder why I don't have 3.3 core by default though, the x.org site notes that you need LLVM 3.5 maybe that's it?

  7. #7
    Join Date
    Jan 2009
    Posts
    598

    Default

    You need LLVM 3.5, which hasn't been released yet, so you have to compile it manually from git or svn. Then, you have to reconfigure and recompile Mesa. The Mesa ./configure script must print that it found LLVM 3.5.

  8. #8
    Join Date
    Feb 2013
    Posts
    253

    Default

    Fglrx is 50% faster than the open source driver (in unigine heaven, anyways)

    Thanks for the help.

  9. #9
    Join Date
    Oct 2012
    Posts
    114

    Default

    Quote Originally Posted by marek View Post
    You need LLVM 3.5, which hasn't been released yet, so you have to compile it manually from git or svn. Then, you have to reconfigure and recompile Mesa. The Mesa ./configure script must print that it found LLVM 3.5.
    is LLVM 3.5 the same as LLVM 3.4.1? if not, does LLVM 3.4.1 help somehow?
    Last edited by asdfblah; 04-12-2014 at 09:06 PM.

  10. #10
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,284

    Default

    Where are you seeing LLVM 4.1 ? The most recent release is 3.4 and 3.5 is "work in process" :

    http://llvm.org/releases/download.html

    EDIT -- ahh, I see, you meant 3.4.1... but not sure where you are seeing that either

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •