Results 1 to 3 of 3

Thread: My Firefox plugin for watching videos without flash

  1. #1
    Join Date
    Aug 2011
    Posts
    6

    Default My Firefox plugin for watching videos without flash

    Hi,

    I've created a Firefox plugin to watch some videos without flash. It has passed preliminary review by Mozilla but according to the reviewer the videos on youtube can't be played

    This is in the console:

    Error: TypeError: video_info.videos[0] is undefined
    Source File: chrome://vwof/content/player.js
    I do not question the wisdom of reviewers, but my "problem" is that I tested it on both linux and windows and I don't have this issue.

    You may be interested by this plugin for your usage, and maybe helps me with the error if you cannot load some youtube videos.

    https://addons.mozilla.org/en-US/fir...without-flash/

    About the addon, how it works and what it can and cannot do :

    I know that some greasmonkey scripts and other solutions exist to play videos that would had need to use flash,
    what I offer new is a simple plugin ready to use, also it can detect embed videos with no needs to code a module for each site, but for each video providers.

    Each module is a jsm (javascript module) that search the video source and give it to firefox. It use a mix on XPath, Regex and DOM. so new videos can be supported fairly easily.

    I am using it without major issus, at least for the sites I go on a daily bases (that use mostly youtube, blip and springboard) , so I thought it may interest firefox / linux users that do not want to have adobe flash on there computer.

  2. #2
    Join Date
    Jul 2009
    Location
    Germany
    Posts
    438

    Default

    It seems to work good here as soon as I disable the flashblock plugin, but I only tried with 2 videos on youtube.
    With flashblock active the video doesn't start after clicking "watch without flash" and selecting the video quality. I also tried to open it in a new tab.

  3. #3
    Join Date
    Aug 2011
    Posts
    6

    Default

    thanks for the feedback
    unfortunately I don't know how to fix this issue for now.
    If someone want the support of a site/embed video feel free to ask on this thread,
    and most importantly I really want to fix the reported youtube problem but it always works despite having test it on several OS and firefox versions

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •