Results 1 to 3 of 3

Thread: some problems with x11perf test

  1. #1
    Join Date
    Sep 2013
    Posts
    8

    Default some problems with x11perf test

    my cpu is powerpc. I found some problems with x11perf test.
    1. drawing rectangle. e.g. x11perf -rect100
    using radeon driver :

    using fbdev driver: x11perf -rect100


    2. e.g. x11perf -compwinwin500
    using radeon driver :

    using fbdev driver:


    3. now my video card has two dvi interface. I must using a DVI to VGA adapter to connect my monitor. if i use a dvi cable to connect my moniter directly, when i use x11perf -move, it shows errors below.
    -------------------------------------
    root@generic-powerpc:~# x11perf -move
    x11perf - X11 performance program, version 1.2
    The X.Org Foundation server version 11499001 on :0
    from generic-powerpc
    Fri Dec 14 12:23:50 2012

    Sync time adjustment is 0.1799 msecs.

    [drm:rv770_copy_dma] *ERROR* radeon: moving bo (-2).
    Unable to handle kernel paging request for data at address 0x00000004
    Faulting instruction address: 0xc029e810
    Oops: Kernel access of bad area, sig: 11 [#1]
    SMP NR_CPUS=2 MPC86xx HPCN
    Modules linked in:
    CPU: 0 PID: 2350 Comm: Xorg Not tainted 3.10.7 #2
    task: ef84e300 ti: ef86e000 task.ti: ef86e000
    NIP: c029e810 LR: c0268a28 CTR: c029ef2c
    REGS: ef86f950 TRAP: 0300 Not tainted (3.10.7)
    MSR: 00009032 <EE,ME,IR,DR,RI> CR: 24044422 XER: 20000000
    DAR: 00000004, DSISR: 40000000

    GPR00: c029f33c ef86fa00 ef84e300 00000000 00000000 00000001 00000000 ef86fb88
    GPR08: c088f260 c029ef2c 00000004 00009032 008dd000 1020f934 10264458 103f1e90
    GPR16: 10527258 0ef93994 000000c0 00040004 00000000 00000000 ef87c4e0 00000000
    GPR24: 00000000 ef87c550 c0742f74 00000001 00000000 ef86fb88 c49f1630 ef87c4e0
    NIP [c029e810] radeon_fence_ref+0x8/0x48
    LR [c0268a28] ttm_bo_move_accel_cleanup+0x6c/0x2a0
    Call Trace:
    [ef86fa00] [c0010cbc] ret_from_except+0x0/0x14 (unreliable)
    [ef86fa40] [c029f33c] radeon_move_blit.isra.10+0x118/0x194
    [ef86fa80] [c029f468] radeon_bo_move+0xb0/0x2e8
    [ef86fb10] [c0266c34] ttm_bo_handle_move_mem+0x204/0x3ac
    [ef86fb80] [c0267030] ttm_mem_evict_first+0x254/0x458
    [ef86fc20] [c02678f4] ttm_bo_mem_space+0x254/0x308
    [ef86fc60] [c0267a6c] ttm_bo_move_buffer+0xc4/0x150
    [ef86fcc0] [c0267b88] ttm_bo_validate+0x90/0x170
    [ef86fcd0] [c0267f3c] ttm_bo_init+0x2d4/0x3a0
    [ef86fd10] [c02a026c] radeon_bo_create+0x11c/0x168
    [ef86fd60] [c02b2520] radeon_gem_object_create+0x94/0x174
    [ef86fda0] [c02b2a0c] radeon_gem_create_ioctl+0x78/0x178
    [ef86fdd0] [c024cbdc] drm_ioctl+0x3e0/0x4b0
    [ef86fea0] [c00d0bfc] do_vfs_ioctl+0x98/0x768
    [ef86ff10] [c00d130c] SyS_ioctl+0x40/0x74
    [ef86ff40] [c00105a8] ret_from_syscall+0x0/0x38
    --- Exception: c01 at 0xff0ed3c
    LR = 0xff9526c
    Instruction dump:
    7c0803a6 4e800020 80010014 38600000 bbc10008 38210010 7c0803a6 4e800020
    3860ffdd 4bffffd0 39430004 7c0004ac <7d205028> 31290001 7d20512d 40a2fff4
    ---[ end trace d2561852ce0c4f0b ]---

    INFO: rcu_sched self-detected stall on CPU { 0} (t=21000 jiffies g=5472 c=5471 q=2)
    CPU: 0 PID: 1290 Comm: kworker/0:2 Tainted: G D 3.10.7 #2
    Workqueue: events ttm_bo_delayed_workqueue
    Call Trace:
    [c4d6db90] [c0008754] show_stack+0x48/0x150 (unreliable)
    [c4d6dbd0] [c00804cc] rcu_check_callbacks+0x2f4/0x6a0
    [c4d6dc30] [c002de28] update_process_times+0x3c/0x68
    [c4d6dc50] [c0066198] tick_sched_timer+0x68/0xb0
    [c4d6dc80] [c0044b18] __run_hrtimer.isra.26+0x54/0xd8
    [c4d6dca0] [c0045a50] hrtimer_interrupt+0x1ac/0x48c
    [c4d6dd20] [c000ae18] timer_interrupt+0x1d8/0x210
    [c4d6dd50] [c0010cbc] ret_from_except+0x0/0x14
    --- Exception: 901 at _raw_spin_lock+0x28/0x60
    LR = ttm_bo_cleanup_refs_and_unlock+0x34/0x20c
    [c4d6de10] [00001032] 0x1032 (unreliable)
    [c4d6de50] [c02661dc] ttm_bo_delayed_delete+0xec/0x250
    [c4d6de90] [c0266360] ttm_bo_delayed_workqueue+0x20/0x64
    [c4d6dea0] [c003a020] process_one_work+0x124/0x348
    [c4d6dec0] [c003a674] worker_thread+0x12c/0x3a8
    [c4d6def0] [c0040c54] kthread+0xa8/0xac
    [c4d6df40] [c00106d0] ret_from_kernel_thread+0x5c/0x64

  2. #2
    Join Date
    Sep 2013
    Posts
    8

    Default

    Can anyone give me advice, help!

  3. #3
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    Quote Originally Posted by Top_lee View Post
    Can anyone give me advice, help!
    Suggest you try #radeon IRC on freenode if you're in a hurry. Unless it's a known problem with known fix you'll probably get asked to file a bugzilla ticket to track the issue.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •