Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Radeon Driver Now Enables GLAMOR By Default

  1. #11

    Default

    Quote Originally Posted by droste View Post
    That's really surprising to hear. Do you have an example for such a 2D operation? The usual opinion I hear is catalyst was/is bad at 2D and the open source driver is better there. And from my own experience (rage 128, ati radeon 9800, ati radeon x1950, radeon hd 5770) I never had problems with 2D so far.
    For me (A8-5500) catalyst is faster with 2d than radeon on Xfce. I dont use compositing.
    The bad thing for catalyst is video playback - excepting xbmc, no video player can play tear-free with the tearfree (forced triple buffering, uses extra video memory) option not enabled - radeon is way better out of the box in this regard.

  2. #12
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,185

    Default

    Certainly it's better than the blob, but that doesn't mean it's perfect. Back when I switched from Matrox to Ati, I lost 2d speed.

    Do check you're using 7.2.0, there were some 2d optimizations in that version.

  3. #13
    Join Date
    Feb 2012
    Posts
    8

    Default

    Hmmm. Most 2d drawing is in good shape these days, but there are some things here and there.

    Just moving a window around in twm (I know :-) used to be slow and laggy, but it's good now. At times there's some lag between window updates - when rapidly dragging a window across the screen, the window may get redrawn at say 20 discrete points rather appearing to be perfectly continuous - but each individual update is instantaneous.

    Scrolling in an xterm with antialiased text used to be slow, but it's pretty zippy now (looks like around 2500 lines/sec in an 80 line tall windows, based on a completely unscientific test just now).

    One area of concern is basic X drawing operations (XDrawLine and friends). Again, I haven't noticed it so much in recent times. Maybe that's just because everyone is using Cairo or Qt or whatever. But there's a little vector-style 3d game I hack on once in a while that uses the low level X calls. It's always drawn around 30-35 fps on this box. I dusted it off last night, recompiled it, and now it only does 9-10, with every optimizing flag in the book turned on. So that might be an example.

    The only serious 2d drawing problem left is with any kind of 2d operation in Gimp - rubberbanding for rectangle selection, placement of the measurement tool, using the airbrush, paintbrush, clone, smudge tools... all horribly, horribly slow. Of course, that could be caused by a billion different things, but it's definitely 2d related.

    Long story short, there's definitely some kind of 2d weirdness going on, although it has improved steadily over time. I get the impression that 98% of all 2d operations works great, but a few specific calls maybe are performance killers. That kind of diagnostic work is out of my league, though.

    At any rate, the entire Linux graphics stack, and particularly Mesa's r600g driver, have made fantastic progress in the past 2-3 years, so there's every chance that these remaining things will improve over time. I'll give Glamor another shot shortly and see what happens. If that doesn't work out, something else will at some point.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •