Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: AMD RadeonSI Graphics Driver Still Troublesome On Linux

  1. #21
    Join Date
    Aug 2008
    Location
    Tokyo, Japan
    Posts
    39

    Default

    Quote Originally Posted by madbiologist View Post
    Also, this commit made on 10th September 2013, fixes hangs in Unigine Tropics and various games - see FDO bug 69340
    The bug fixed by that commit also causes most textures to be untiled, which could have a negative impact on performance.

  2. #22
    Join Date
    Nov 2009
    Location
    Italy
    Posts
    993

    Default

    Quote Originally Posted by Rakot View Post
    Hello, Alex,

    I have muxless laptop with intel hd 4000 + radeon 7750M. So physically there is no display connected to discrete graphic card. I have the following results of unigine tropics benchmark (1024x768 with all high settings):
    Code:
    intel hd 4000                   22.7 fps
    radeon 7750M (fglrx)            44.9 fps
    radeon 7750M (radeonsi auto)     9.6 fps
    radeon 7750M (radeonsi high)    24.1 fps
    Software:
    kernel 3.11.1 with dpm enabled
    The rest is from today's git

    With auto my radeon GPU is always in low state:
    Code:
    uvd    vclk: 0 dclk: 0
    power level 0    sclk: 30000 mclk: 15000 vddc: 850 vddci: 900 pcie gen: 2
    Only using high performance level helps me. In bug report 69395 you attached a patch. Will it help in my laptop's case?

    Also do you know what is the state of dynamic switching of discrete GPU? Dave merged nouveau patches for nvidia and his branch for radeons wasn't touched for three weeks. Is there a chance to have this support in 3.12 kernel?
    Hi,
    The patch did work for me, you should try it

    Also, if someone is interested here is my backported graphic stack for the kernel 3.11.1:
    http://www.linuxsystems.it/linux-drm...ack-backports/

  3. #23
    Join Date
    Mar 2012
    Posts
    67

    Default

    Quote Originally Posted by darkbasic View Post
    Hi,
    The patch did work for me, you should try it

    Also, if someone is interested here is my backported graphic stack for the kernel 3.11.1:
    http://www.linuxsystems.it/linux-drm...ack-backports/
    I saw you bug report. I'll give your patches a try. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •