Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: AMD Publishes HDA Audio GPU Documentation

  1. #21
    Join Date
    Nov 2009
    Location
    Italy
    Posts
    934

    Default

    Quote Originally Posted by agd5f View Post
    Support for SI/TN and newer hardware was added in 3.12. Additionally, with 3.12 you no longer need to boot with radeon.audio=1. You can enable/disable audio on the fly with xrandr. E.g., xrandr --output HDMI-0 --set audio auto
    Really? I did some tests with 3.12 and I thought it didn't work because I didn't know of the new xrandr option.

    Any chance to fix QT's raster engine? SI is starting to be fast and supports lots of features, it's a pity being not able to use it

  2. #22
    Join Date
    Dec 2007
    Posts
    2,371

    Default

    Quote Originally Posted by HokTar View Post
    That didn't work. Setting radeon.audio=1 helped, though.
    Are you sure you were using a recent 3.12 kernel? Make sure your kernel has:
    http://git.kernel.org/cgit/linux/ker...1b124a6d2fa5b0

  3. #23
    Join Date
    Feb 2011
    Posts
    137

    Default

    Here we go: http://mailman.alsa-project.org/pipe...er/066578.html

    Have fun with testing.

  4. #24
    Join Date
    Dec 2009
    Posts
    338

    Default

    Quote Originally Posted by agd5f View Post
    Are you sure you were using a recent 3.12 kernel? Make sure your kernel has:
    http://git.kernel.org/cgit/linux/ker...1b124a6d2fa5b0
    I'm using 3.12-rc1 from the ubuntu kernel ppa, I suppose it should be there, though I haven't checked.

    Edit: I checked that the patch was merged 3-4 days before rc1 was tagged so I suppose my kernel must have it, too.

    I only get:
    ~$ xrandr --output HDMI-0 --set audio enable
    X Error of failed request: BadName (named color or font does not exist)
    Major opcode of failed request: 140 (RANDR)
    Minor opcode of failed request: 11 (RRQueryOutputProperty)
    Serial number of failed request: 37
    Current serial number in output stream: 37

    If I write "auto", "on", etc. it's still the same story.
    As I said, with radeon.audio=1 works, which is already good enough for me until ubuntu sorts itself out.
    Last edited by HokTar; 09-22-2013 at 05:30 PM.

  5. #25
    Join Date
    Sep 2012
    Posts
    88

    Default

    Quote Originally Posted by HokTar View Post
    I'm using 3.12-rc1 from the ubuntu kernel ppa, I suppose it should be there, though I haven't checked.

    Edit: I checked that the patch was merged 3-4 days before rc1 was tagged so I suppose my kernel must have it, too.

    I only get:
    ~$ xrandr --output HDMI-0 --set audio enable
    X Error of failed request: BadName (named color or font does not exist)
    Major opcode of failed request: 140 (RANDR)
    Minor opcode of failed request: 11 (RRQueryOutputProperty)
    Serial number of failed request: 37
    Current serial number in output stream: 37

    If I write "auto", "on", etc. it's still the same story.
    As I said, with radeon.audio=1 works, which is already good enough for me until ubuntu sorts itself out.
    What output do you get for:
    Code:
    cat /var/log/Xorg.0.log |grep "X Server" && xrandr -v

  6. #26
    Join Date
    Dec 2009
    Posts
    338

    Default

    Quote Originally Posted by Tyler_K View Post
    What output do you get for:
    Code:
    cat /var/log/Xorg.0.log |grep "X Server" && xrandr -v
    ~$ cat /var/log/Xorg.0.log |grep "X Server" && xrandr -v
    X.Org X Server 1.13.4
    xrandr program version 1.3.5
    Server reports RandR version 1.4


    So is my xrandr version too old? That would be simple explanation, I guess.
    Btw, thanks for your help!

  7. #27
    Join Date
    Feb 2011
    Posts
    137

    Default

    With v2.0 specs released. Anssi could implement Bitstream Audio within minutes:



    :-)

    Thanks all involved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •