Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Radeon HDMI Audio issues with Kernel 3.12-rc2

  1. #11
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,103

    Default

    Just curious, what's the official solution for toggling non-X things in non-X environment, where xrandr obviously doesn't work?

    HDMI audio, over/underscan, perhaps some other properties.

  2. #12
    Join Date
    Jun 2009
    Posts
    36

    Default

    Thanks for your answer Alex !

  3. #13
    Join Date
    Feb 2008
    Location
    Santiago, Chile
    Posts
    242

    Default

    Newbie question: with Linux 3.12, will I need to pass radeon.audio=1 to the kernel line? Or I won't need to do that anymore?

  4. #14
    Join Date
    Dec 2007
    Posts
    2,371

    Default

    Quote Originally Posted by curaga View Post
    Just curious, what's the official solution for toggling non-X things in non-X environment, where xrandr obviously doesn't work?

    HDMI audio, over/underscan, perhaps some other properties.
    You can access them via ioctl the same way the ddx does.

  5. #15
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,103

    Default

    So no existing tool, ok. Seems to even be discoverable. I sense a market opening here

  6. #16
    Join Date
    Sep 2013
    Location
    Tivoli (RM) - Italy
    Posts
    3

    Default

    Quote Originally Posted by Tyler_K View Post
    Alex pushed a related change today: http://lists.freedesktop.org/archive...er/047531.html
    It seems It is included in the current 3.12-rc7 linux kernel release.

    http://lkml.indiana.edu/hypermail/li...0.3/01253.html

  7. #17
    Join Date
    Sep 2013
    Location
    Tivoli (RM) - Italy
    Posts
    3

    Default

    Quote Originally Posted by Tyler_K View Post
    Alex pushed a related change today: http://lists.freedesktop.org/archive...er/047531.html
    It seems It was included in the current 3.12-rc7 linux kernel release.

    http://lkml.indiana.edu/hypermail/li...0.3/01253.html

  8. #18
    Join Date
    Mar 2012
    Posts
    318

    Default no audio with final 3.12?

    I just upgraded from kernel 3.7.9+fglrx to 3.12 final+oss drivers on my E-350 system. Sound is gone completely...
    help please

    dmesg | grep audio
    [ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.12.0-3-desktop root=UUID=172ac2d8-b994-4611-b523-1ad921303bfa resume=/dev/disk/by-id/ata-M4-CT128M4SSD2_000000001130031527B5-part1 splash=silent quiet showopts radeon.dpm=1 radeon.audio=1
    [ 0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.12.0-3-desktop root=UUID=172ac2d8-b994-4611-b523-1ad921303bfa resume=/dev/disk/by-id/ata-M4-CT128M4SSD2_000000001130031527B5-part1 splash=silent quiet showopts radeon.dpm=1 radeon.audio=1
    [ 4.694352] [drm] Enabling audio 0 support

  9. #19
    Join Date
    Mar 2012
    Posts
    318

    Default

    Quote Originally Posted by tomtomme View Post
    I just upgraded from kernel 3.7.9+fglrx to 3.12 final+oss drivers on my E-350 system. Sound is gone completely...
    help please
    I uploaded additional info:
    http://www.alsa-project.org/db/?f=11...155729763280d8

  10. #20
    Join Date
    Mar 2012
    Posts
    318

    Default pavucontrol

    after purging pulse, then reinstalling it and opening pavucontrol the master volume was muted, while this is NOT shown in kmix, there is no master slider like in pavucontrol. So maybe a kmix feature missing. Now I have sound, but not in flash/firefox.... rest however works...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •