Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: X.Org Security Advisory For X11 Going Back To 1993

  1. #21
    Join Date
    Jul 2013
    Posts
    381

    Default

    Quote Originally Posted by curaga View Post
    WTF is gedit doing? None of the apps I use take that long to launch _total_, not just X server portions.
    Well, you probably have a much faster computer than what the guy was using :P

    It was just an example of how X11 does affect performance of everything, especially on computers older than 3 or 4 years. On my computer, Gedit takes ~1.5 seconds to open after a cold boot. That's presumably because my computer is 6 years old and was "meh" when I got it but I can probably assume that it would open faster on Wayland/Mir/whatever

  2. #22
    Join Date
    Jan 2011
    Posts
    1,287

    Default

    Quote Originally Posted by curaga View Post
    WTF is gedit doing? None of the apps I use take that long to launch _total_, not just X server portions.
    That's mainly a problem with informing times without informing hardware.

  3. #23
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,103

    Default

    No, the computer's beefiness shouldn't have anything to do with app startup times, as they are all IO, not computation. I have very fast startup times on old hw too (well I do run in RAM just for that purpose).

    The point of my post was that gedit, or its toolkit, are doing something wrong.

  4. #24
    Join Date
    Jul 2009
    Posts
    278

    Default

    Quote Originally Posted by Daktyl198 View Post
    Well, you probably have a much faster computer than what the guy was using :P
    This was on a specced-out 2011 (Sandy Bridge) MacBook Air. So, not only is it quite a fast machine to begin with, but I/O is barely a thing as it's got an SSD. Intel graphics also provides the best case for GPU blocking, since when you bounce between CPU and GPU rendering, you don't have to transfer the buffer back and forth over PCIE! If I was on a system with a discrete GPU, those numbers would've been worse ...

    Exactly what was happening, I'm not sure. But what I did was to stick profiling in libX11 at the point where it waits - blocks - for a reply from the X server. This reply had a simple gettimeofday() counter, and I added up the cumulative time when I started gedit from a terminal. I ran this about 10-15 times and picked the highest number. That's all.

  5. #25
    Join Date
    Jul 2009
    Posts
    278

    Default

    Quote Originally Posted by curaga View Post
    WTF is gedit doing? None of the apps I use take that long to launch _total_, not just X server portions.
    Guess you aren't using Evolution then. Or you have fewer tabs than I do in Chrome. (And I've since upgraded to the Ivy Bridge model.)

    Anyway, GEdit doesn't take 1.5 seconds to launch on my machine every time. Usually it's blindingly fast. Sometimes it's a tad sluggish. And occasionally (not all the time, but enough to show up as one in less-than-fifteen in my measurements), it takes a pathologically long amount of time to launch. Why? Because the X server's taking staggering amounts of time to reply.

  6. #26
    Join Date
    Sep 2012
    Posts
    343

    Default

    Quote Originally Posted by Daktyl198 View Post
    It was just an example of how X11 does affect performance of everything, especially on computers older than 3 or 4 years. On my computer, Gedit takes ~1.5 seconds to open after a cold boot. That's presumably because my computer is 6 years old and was "meh" when I got it but I can probably assume that it would open faster on Wayland/Mir/whatever
    On my PC simple applications start immediately, big applications like Libre Office in 1 second when their files are cached in memory. First start is slower because of slow hard drive.

  7. #27
    Join Date
    May 2011
    Posts
    1,498

    Default

    Quote Originally Posted by daniels View Post
    I ran this about 10-15 times and picked the highest number. That's all.
    What was the median?

  8. #28
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,103

    Default

    Quote Originally Posted by daniels View Post
    Anyway, GEdit doesn't take 1.5 seconds to launch on my machine every time. Usually it's blindingly fast. Sometimes it's a tad sluggish. And occasionally (not all the time, but enough to show up as one in less-than-fifteen in my measurements), it takes a pathologically long amount of time to launch. Why? Because the X server's taking staggering amounts of time to reply.
    I think you're hitting the same bug I hit ~2 years ago: https://bugs.freedesktop.org/show_bug.cgi?id=46578 or google for "slow xquerypointer". Ajax promised fixes to 1.12 or 1.13 at latest, nothing has been done to this day AFAIK.

    The symptoms sound very much alike, the server occasionally ignores you in favor of some other client, causing latency.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •