Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Wine 1.7.4 Continues With The D3D Command Stream

  1. #11
    Join Date
    Sep 2010
    Posts
    683

    Default

    Quote Originally Posted by birdstream View Post
    Hard to say, really. Because the framrate on my system may vary a lot during gameplay depending on the map. Typically, if there is a lot of destructive objects (such as houses you can ram down and such) on screen the framerate may drop as to the low 20's, with or without the patch. This is something i believe some windows users seem to suffer from too, so it's likely related to the game itself. But generally, without the patch im somewhere around 25 fps and with the patch around 50-60 fps. So yeah, a little more than double the performance If i look up in the air or over a big empty field using the patch the fps shoots to over 100... this is with "ultra" settings!

    Hmm.. should not be any issues really to install through PoL. What exactly happens when you try to start the game? What graphics card/drivers do you use? I'm on Ubuntu 13.04 64-bit using kernel 3.8.0 and NVidia driver 319.60 (manually installed)

    1) I get constant crashes and restarts of game during torrent download if I use net install.
    2) Black textures (or rather lack thereof), when I used full install. And I could not start game again. :|

    Now I have fresh reinstallation of OpenSuSE with 3.12rc5 + Mesa 10 from pontostroy repos.
    And 1) still presist. I'm downloading full instal atm.

    And I'm using this tut:
    http://forum.worldoftanks.eu/index.p...x-perfect-way/

  2. #12
    Join Date
    Apr 2013
    Posts
    42

    Default

    Quote Originally Posted by przemoli View Post
    1) I get constant crashes and restarts of game during torrent download if I use net install.
    2) Black textures (or rather lack thereof), when I used full install. And I could not start game again. :|

    Now I have fresh reinstallation of OpenSuSE with 3.12rc5 + Mesa 10 from pontostroy repos.
    And 1) still presist. I'm downloading full instal atm.

    And I'm using this tut:
    http://forum.worldoftanks.eu/index.p...x-perfect-way/
    I suppose you're running on intel integrated graphics then? You should really get a dedicated graphics card, preferrably NVidia. In fact, the minimum Windows system specs for this game calls for one... I don't know what kind of budget you're on, but a GT 630 should do. On my system with NVidia GTX660Ti the bottleneck is the CPU, a i7-2700K@3.5Ghz (running 3.9Ghz boost mode), because the game engine is single threaded. This is why the D3D command stream patch gives a nice boost to the game since by doing all OpenGL calls from a separate thread it frees CPU time for the game engine itself...

    As far as the crashes, i couldn't say, really. I do experience them myself sometimes. Maybe you should go with a stable kernel?

  3. #13
    Join Date
    Sep 2010
    Posts
    683

    Default

    Quote Originally Posted by birdstream View Post
    I suppose you're running on intel integrated graphics then? You should really get a dedicated graphics card, preferrably NVidia. In fact, the minimum Windows system specs for this game calls for one... I don't know what kind of budget you're on, but a GT 630 should do. On my system with NVidia GTX660Ti the bottleneck is the CPU, a i7-2700K@3.5Ghz (running 3.9Ghz boost mode), because the game engine is single threaded. This is why the D3D command stream patch gives a nice boost to the game since by doing all OpenGL calls from a separate thread it frees CPU time for the game engine itself...

    As far as the crashes, i couldn't say, really. I do experience them myself sometimes. Maybe you should go with a stable kernel?
    Game crashed. Not whole system

    I have AMD 5730M. Its Good GPU capable of 50FPS on Win for tweaked WoT settings (long draw distance, disabled bells & whistles). Catalyst did not work nice with wine though -> 3FPS ...

    With r600g I had actually better luck few months ago (14FPS!), but I'm revisiting WoT+Wine now with recent improvements to r600g+SB, krenels ondemand governor, and wine command streamer.


    So:
    WoT runs OK on my system on Win (or rather did 1y ago when I had Win on my hw)
    WoT runs NOT OK on Catalyst (and besides r600g is better now -> vdpau...)

    Have troubles with finding instruction about what winetricks install to get WoT working.
    And would welcome info on tweaking WoT for wine too. (Now I know that triple buffering should be disabled...)

  4. #14
    Join Date
    Jun 2009
    Posts
    155

    Default

    Quote Originally Posted by przemoli View Post
    Game crashed. Not whole system

    I have AMD 5730M. Its Good GPU capable of 50FPS on Win for tweaked WoT settings (long draw distance, disabled bells & whistles). Catalyst did not work nice with wine though -> 3FPS ...

    With r600g I had actually better luck few months ago (14FPS!), but I'm revisiting WoT+Wine now with recent improvements to r600g+SB, krenels ondemand governor, and wine command streamer.


    So:
    WoT runs OK on my system on Win (or rather did 1y ago when I had Win on my hw)
    WoT runs NOT OK on Catalyst (and besides r600g is better now -> vdpau...)

    Have troubles with finding instruction about what winetricks install to get WoT working.
    And would welcome info on tweaking WoT for wine too. (Now I know that triple buffering should be disabled...)
    AMD hardware is good but software (privative and opensource, opensource in minor way (AMD free documentation) but only for radeon HD6xxx and before) especially with wine is bad and intel support on wine is worst than AMD

    However AMD had improvements in lastest 4 years (I say 4 years because this time had probing wine than AMD and NVIDIA hardware, if you have interested can consult my blog: gamesonwine.blogspot.com)

    On my case i think probe again AMD next year (AMD A4 3300 - IGP Radeon HD6410D) (because next year AMD free information and kernel patches stay in better form)

    if you want compatibility and performance on games using wine, your only option for this moment is NVIDIA

    My hardware specs

    Wine 1.7.4
    Nvidia Drivers 331.13
    Kubuntu 13.10 32Bit - Kernel 3.11.0.11 PAE
    CPU: AMD Fusion A4 3300 2.5Ghz (Dual-Core) Stock Clock
    MEM: 8GB DDR3 1333 (2x4) Patriot value (128 bit dual channel: 21.3 gb/s)
    GPU: Zotac Nvidia Geforce GT630 (GK208 28nm: 384 Shaders / 8 ROPS) Zone Edition Passive Cooling 2GB DDR3 64bit 1800Mhz (14.4Gb/s)
    BOARD: MSI A55M P35

    Last edited by pinguinpc; 10-19-2013 at 09:07 AM.

  5. #15
    Join Date
    Apr 2013
    Posts
    42

    Default

    Quote Originally Posted by przemoli View Post
    Game crashed. Not whole system
    The kernel is very much involved with graphics drivers, so it was just a thought..

    I have AMD 5730M. Its Good GPU capable of 50FPS on Win for tweaked WoT settings (long draw distance, disabled bells & whistles). Catalyst did not work nice with wine though -> 3FPS ...

    With r600g I had actually better luck few months ago (14FPS!), but I'm revisiting WoT+Wine now with recent improvements to r600g+SB, krenels ondemand governor, and wine command streamer.
    Just another testament to just how shitty linux support AMD gives, then..
    The times i've dealt with AMD/Radeon on linux it's mostly been a pain in the arse =( Performance in Linux is just horrible with AMD..
    Compare this to the NVidia binary blob which always just works and is on par with the Windows driver nowadays.


    So:
    WoT runs OK on my system on Win (or rather did 1y ago when I had Win on my hw)
    WoT runs NOT OK on Catalyst (and besides r600g is better now -> vdpau...)
    So conclude it all, as long as you're stuck with radeon you'd be better off with dualbooting and run Windows to play WoT. Atleast for now

    Have troubles with finding instruction about what winetricks install to get WoT working.
    And would welcome info on tweaking WoT for wine too. (Now I know that triple buffering should be disabled...)
    The easiest way is to grab the latest PlayOnLinux and install WoT from there, can't make it much easier Otherwise the winetricks dependencies to install is: d3dx9 d3dx9_43 vcrun2008 msxml3 wininet ie7

  6. #16
    Join Date
    Sep 2010
    Posts
    683

    Default

    I think that I narrowed suspect to winetricks ie7 ... which wont install correctly
    And WoT do not create preferences.xml (locate find nothing..).

    And I'm not going back to Win :P (nor changing to Catalyst The Bastard )
    (If anything I will play EU4 more on Steam. WoT+Wine is first game I have troubles with...)


    Will check if PoL works. But first I must find a way to coax it into using full install I already downloaded.
    Last edited by przemoli; 10-20-2013 at 03:24 AM.

  7. #17
    Join Date
    Apr 2013
    Posts
    42

    Default

    Quote Originally Posted by przemoli View Post
    I think that I narrowed suspect to winetricks ie7 ... which wont install correctly
    And WoT do not create preferences.xml (locate find nothing..).

    And I'm not going back to Win :P (nor changing to Catalyst The Bastard )
    (If anything I will play EU4 more on Steam. WoT+Wine is first game I have troubles with...)


    Will check if PoL works. But first I must find a way to coax it into using full install I already downloaded.
    Have you tried using another Linux distro? like ubuntu, lubuntu,xubuntu or similar?

  8. #18
    Join Date
    Sep 2010
    Posts
    683

    Default

    Quote Originally Posted by birdstream View Post
    Have you tried using another Linux distro? like ubuntu, lubuntu,xubuntu or similar?
    Ubu 13.04 = 3.11+9.2 from oilbaf's ppa. Eu4 and CKII from Steam work the same. Do not play any other games.

    Edit:

    Have modified PoL script that allow for installation from already downloaded instal files. Maybe this time it will work...
    Last edited by przemoli; 10-20-2013 at 03:46 PM.

  9. #19
    Join Date
    Sep 2010
    Posts
    683

    Default

    Quote Originally Posted by przemoli View Post
    Ubu 13.04 = 3.11+9.2 from oilbaf's ppa. Eu4 and CKII from Steam work the same. Do not play any other games.

    Edit:

    Have modified PoL script that allow for installation from already downloaded instal files. Maybe this time it will work...
    After some 10xth try. I got WoT installed with PoL (and have that script, will try to mainline it).

    1.5.9 Works OK. (7-24 fps, but SMOOTH and PLAYABLE, so those FPS's are reported wrong probably...)
    1.7.1+CSMT from PoL Works OK (maybe a bit faster, 3D works well, 2D Gui have flickering text sometimes, but always draw properly after 1-2 sec.)

    Will check if 3.12 give it a boost.

  10. #20
    Join Date
    Nov 2012
    Location
    France
    Posts
    575

    Default

    Quote Originally Posted by birdstream View Post
    but a GT 630 should do.
    GT 630 is a rebrand of the GT 440. Both are terrible, and you should avoid the GT 620, 630 and 640s (usage of DDR3 being the main problem). 610 has a use if you need more than 2 screens (and are not playing resource intensive games).

    If you have the budget, get a GTX 660, it's way better than 650/650 Ti/650 Ti Boost.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •