Results 1 to 3 of 3

Thread: TF2 fails to run when installed to a non-default library folder

  1. #1
    Join Date
    Oct 2013
    Posts
    13

    Default TF2 fails to run when installed to a non-default library folder

    Code:
    Test Run Command: cd /home/username/.phoronix-test-suite/installed-tests/pts/tf2-1.0.0/ && ./tf2 -fullscreen -novideo -w 1920 -h 1200 2>&1
    
    ./tf2: 2: cd: can't cd to /home/username//.steam/root/SteamApps/common/Team Fortress 2
    ./tf2: 4: ./tf2: ./hl2_linux: not found
    
    Test Result Value: 
    
    The test run did not produce a result.
    I have TF2 installed to a different/non-default library folder which is located on another HDD (Steam -> Settings -> Downloads -> Content Libraries) and it seems that PTS is searching for the game in the default folder which is why the benchmark won't run.

    PTS could read the correct install folder from the ./steam/root/config/config.vdf file in the future but how can I run this test now? Are there any workarounds?

    Thanks!

  2. #2
    Join Date
    Jun 2006
    Location
    Portugal
    Posts
    524

    Default

    Just ran into this, seems to affect all steam-based benchmarks.

    Can this please be fixed? Even the error message given "The test run did not produce a result." is extremely vague and confusing. I have an 128gb SSD for OS/home so I can't have all my steam games on it

  3. #3
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,037

    Default

    UI suggestion: the first time PTS prints "did not produce a result", it should be followed by "if you want to know why, run phoronix-test-suite debug-foo bar".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •