Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Xv on x1400 with Radeon 3/26 version

  1. #11
    Join Date
    Feb 2007
    Posts
    22

    Default Success!

    I installed drm and mesa from git, and now it works! (once I also enabled EXA in xorg.conf).

    The only problem is that there is some horizontal tearing in video playback. Not worse than fglrx has, mind you (and in fglrx the tearing is diagonal). Is there a fix for this?

  2. #12
    Join Date
    Oct 2007
    Posts
    39

    Default

    Quote Originally Posted by elenius View Post
    I installed drm and mesa from git, and now it works! (once I also enabled EXA in xorg.conf).

    The only problem is that there is some horizontal tearing in video playback. Not worse than fglrx has, mind you (and in fglrx the tearing is diagonal). Is there a fix for this?
    I believe agd5f mentioned that vsync is something that will be worked on in-driver in the future. That should help the tearing issue.

  3. #13
    Join Date
    Dec 2007
    Posts
    2,329

    Default

    FWIW, things seem to be somewhat improved with my latest commits. Textured video seems to work ok without the drm now, but EXA render still has issues if the drm isn't loaded.

  4. #14
    Join Date
    Feb 2007
    Posts
    22

    Default

    Can someone point me to instructions on building/installing the radeon driver?

  5. #15
    Join Date
    Dec 2007
    Posts
    2,329

    Default

    this should give you the basics:

    http://www.botchco.com/agd5f/?page_id=2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •