Results 1 to 2 of 2

Thread: Need confirmation: Glest 3.1.x crashes with ATi drivers

Hybrid View

  1. #1
    Join Date
    Apr 2007
    Location
    Mexico City, Mexico
    Posts
    906

    Default Need confirmation: Glest 3.1.x crashes with ATi drivers

    Glest seems to be very unstable on my ATi based laptop. It consistently crashes on the same spot all the time. At first I thought this might be related to 64-bits version of the game, but that has nothing to do with it. My main rig is also running 64-bits Linux and the very same binaries as the laptop, i.e off the distribution's repositories. However on my desktop I have an nVidia graphics card with its respective drivers, while in the Laptop I have an ATi IGP with the fglrx drivers.

    The game consistently crashes on the laptop in any game as soon as I select a pawn unit and start gathering resources, it doesn't matter if it is a Magic's acolyte or a Tech's Pawn. As soon as I mark the target for the unit to start gathering resources (right-click) the game segfaults. However on my desktop the game runs just fine.

    Both machines are running the same distribution (Fedora 8 x86_64) with the game binaries obtained in the same manner (via package manager off the distro's repositories) and only on the laptop the game crashes. Can someone else confirm that this crash may be related to fglrx?

  2. #2
    Join Date
    Mar 2007
    Location
    MN, United States
    Posts
    285

    Default

    I just tried it with my ATI card and yeah, it froze right when you said it does. We'll see if the next driver release miraculously fixes it. If you're curious I'm running 64-bit Debian with a x1600XT (dedicated card) so its definitely the driver.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •