Results 1 to 3 of 3

Thread: ubuntu 8.04 9800PRO ati 8.4 drivers = no direct rendering

  1. #1

    Default ubuntu 8.04 9800PRO ati 8.4 drivers = no direct rendering

    basically i get a white screen overlay
    fglrxinfo shows indirect rendering
    ati control centre shows AGP at x0

    here is my xorg.conf file

    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "aticonfig-Screen[0]" 0 0
    EndSection

    Section "Files"
    EndSection

    Section "Module"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "ATI 9800pro"
    Driver "fglrx"
    BusID "PCI:1:0:0"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    Option "TexturedVideo" "on"
    Option "UseFastTLS" "2"
    Option "BusType" "AGP"
    Option "PseudoColorVisuals" "off"
    Option "EnablePageFlip" "true"
    Option "TexturedXrender" "true"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    lsmod = intel_agp 25492 0
    agpgart 34760 2 fglrx,intel_agp

    dmesg grep fglrx shows =
    [ 69.712382] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
    [ 69.823021] [fglrx] Maximum main memory to use for locked dma buffers: 928 MBytes.
    [ 69.823065] [fglrx] ASYNCIO init succeed!
    [ 69.823266] [fglrx] PAT is enabled successfully!
    [ 69.824089] [fglrx] module loaded - fglrx 8.47.3 [Mar 29 2008] on minor 0
    [ 83.675267] [fglrx] Internal AGP is not supported in 2.6 kernel.
    [ 112.065584] [fglrx] Internal AGP is not supported in 2.6 kernel.

  2. #2
    Join Date
    Jan 2008
    Location
    Darmstadt - Germany
    Posts
    6

    Default

    the r300 chip is somehow blacklisted.

    add the following
    /etc/xdg/compiz/compiz-manager
    Skip_Cheks=yes

    After this you should be able to enable the Desktop Effects.

    Cheers

    Sorry, didnt read you post completly you have fglrx enabled sorry.......my one was for radeon drived

  3. #3
    Join Date
    Oct 2007
    Posts
    1

    Default hardy heron on 9800 pro

    I am also having hassles getting compiz to run.

    upgraded from fiesty, where I think i was using xgl and radeon driver ( tried aiglx when 8.42 came out but gave up, it didnt seem to work). it took a while to config the last time around but i got it working, cube, minmax effects, everything all sweet.

    following the upgrade to hardy, fireGL was the default hardware driver listed but was not enabled. compiz and emerald didnt seem to work, so i installed the ati binary driver from app manager.

    that didn't help, and i havent found a way to get it going yet. let u kno if i have any luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •