Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 34

Thread: Arch linux (64bit) - unable to install or benchmark (no output)

  1. #11

    Default

    Hmmm I wonder if it's an ArchLinux PHP configuration problem.

  2. #12
    Join Date
    Sep 2007
    Posts
    36

    Default

    Just to say:-

    Same thing is still happening with 0.5.1 (and arch)



    Quote Originally Posted by Michael View Post
    Hmmm I wonder if it's an ArchLinux PHP configuration problem.

  3. #13
    Join Date
    May 2008
    Location
    UK
    Posts
    465

    Default

    PHP Fatal error: Call to undefined function posix_getpwuid() in /var/local/phoronix-test-suite/pts-core/functions/pts-functions_system.php on line 74

    I just tried the git version and get the above error when I try and run ./phoronix-test-suite diagnostics on archlinux x86_64 using the php.ini file that comes with the source (php.ini-recommended) and not the default arch one. With the default arch one I get nothing at all.

    edit: php version = 5.2.6-1
    Last edited by Aradreth; 05-10-2008 at 12:38 PM.

  4. #14

    Default

    Quote Originally Posted by Aradreth View Post
    PHP Fatal error: Call to undefined function posix_getpwuid() in /var/local/phoronix-test-suite/pts-core/functions/pts-functions_system.php on line 74

    I just tried the git version and get the above error when I try and run ./phoronix-test-suite diagnostics on archlinux x86_64 using the php.ini file that comes with the source (php.ini-recommended) and not the default arch one. With the default arch one I get nothing at all.

    edit: php version = 5.2.6-1
    The posix issue should be fixed in git.

  5. #15
    Join Date
    May 2008
    Location
    UK
    Posts
    465

    Default

    Quote Originally Posted by Michael View Post
    The posix issue should be fixed in git.
    Tested it quickly and is appears to be working now, cheers.

  6. #16
    Join Date
    Sep 2007
    Posts
    36

    Default

    Hi.

    After 'messing' with the php.ini file the installer now actually download files in arch - it does error however - can someone post a working php.ini file - perhaps we can find what options need to be enabled....


    Quote Originally Posted by Aradreth View Post
    Tested it quickly and is appears to be working now, cheers.

  7. #17
    Join Date
    May 2008
    Location
    UK
    Posts
    465

    Default

    Alright I only just was able to try the benchmark properly (internet is a bit slow so the download took a while); anyway everything appeared to download fine but the actual benchmarks do not run and I just get errors an example of which is below:-

    ====================================
    Universe Test Suite
    ====================================

    Running Universe Test Suite...

    PHP Notice: Undefined variable: RESULTS_IDENTIFIER in /var/local/phoronix-test-suite/pts-core/pts-run-benchmark.php on line 222

    ====================================
    LAME MP3 Encoding (Run 1 of 3)
    ====================================

    ./lame: line 3: /usr/bin/time: No such file or directory

    ====================================
    LAME MP3 Encoding (Run 2 of 3)
    ====================================

    ./lame: line 3: /usr/bin/time: No such file or directory

    ====================================
    LAME MP3 Encoding (Run 3 of 3)
    ====================================

    ./lame: line 3: /usr/bin/time: No such file or directory
    PHP Warning: Division by zero in /var/local/phoronix-test-suite/pts-core/functions/pts-functions-run.php on line 386
    The time function works perfectly when I try it myself and "whereis time" gives:-
    time: /usr/include/time.h /usr/man/mann/time.n.gz /usr/share/man/man3p/time.3p.gz /usr/share/man/man1p/time.1p.gz /usr/share/man/man7/time.7.gz /usr/share/man/man2/time.2.gz /usr/share/man/man1/time.1.gz

    but not the path to the binary it is not in /usr/bin/ /bin/ or anywhere else I could think of looking in, nor could I find it with rlocate.
    That's all I had time to look into whilst I avoided working.

    ninja edit:
    PHP Notice: Undefined variable: RESULTS_IDENTIFIER in /home/nuno/download/phoronix-test-suite/pts-core/pts-run-benchmark.php on line 199
    is the only error I could from the nexuiz benchmark; it worked fine otherwise.



    Quote Originally Posted by yossarianuk View Post
    Hi.

    After 'messing' with the php.ini file the installer now actually download files in arch - it does error however - can someone post a working php.ini file - perhaps we can find what options need to be enabled....
    Last edited by Aradreth; 05-11-2008 at 06:34 PM.

  8. #18

    Default

    Quote Originally Posted by Aradreth View Post
    ninja edit:
    PHP Notice: Undefined variable: RESULTS_IDENTIFIER in /home/nuno/download/phoronix-test-suite/pts-core/pts-run-benchmark.php on line 199
    is the only error I could from the nexuiz benchmark; it worked fine otherwise.

    That is fixed in git. It's not an error but just a notice, but it's cleared up anyways in the latest code.

  9. #19
    Join Date
    May 2008
    Location
    UK
    Posts
    465

    Default

    Er right had a proper look at the why time wasn't working... I might have forgotten to install extra/time...
    Working properly (default arch php.ini file) as far as I can tell.

  10. #20
    Join Date
    May 2008
    Posts
    5

    Default

    hi,

    now here is the new output, when I press on enter a lot of time...
    ==> http://pastebin.com/f605b3ae3

    that's weird... I already installef all of theses package and I have more than 10gig on my root slice.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •