Results 1 to 4 of 4

Thread: Ubuntu 8.04 Warning: LookupDrawable()/SecurityLookupDrawable() are deprecated

  1. #1
    Join Date
    Jan 2008
    Posts
    7

    Default Ubuntu 8.04 Warning: LookupDrawable()/SecurityLookupDrawable() are deprecated

    Hello.

    Ever since I updated to the latest Xubuntu (kernel : 2.6.24-16-generic and Xorg 7.3), I get the following line in my Xorg.0.log while playing a certain game (World of Warcraft through Wine).

    Code:
    Warning: LookupDrawable()/SecurityLookupDrawable() are deprecated.  Please convert your driver/module to use dixLookupDrawable().
    This is translated, on-screen, with heavy corruption inside the game (rest of system is unscathed). Sample screenshot (text dissappears + graphical corruption)

    I have played with many xorg.conf options, and this is replicated regardless.
    At the moment, I run with AIGLX disabled.


    Is there any known workaround for this? Or should I just wait for the code to get updated?


    System info:
    Operating system : Xubuntu 8.04
    Processor : Intel Pentium M 1.6 GHz - 400 FSB
    Graphics : Ati Mobility Radeon 9700 with 128 MB
    RAM : 1280 DDR RAM
    (Full system specifications at hxxp://www.netdummy.net/Aspire_2023WLMi.html)

    fglrx driver : 8.4 (april release)

    Regards,

    - Dreamlocked

    EDIT : tested with March 2008 and April 2008 drivers
    EDIT 2 : tested with 2.6.24-17-generic as well
    Last edited by Dreamlocked; 05-09-2008 at 07:14 PM.

  2. #2
    Join Date
    Oct 2007
    Location
    Roanoke, VA
    Posts
    228

    Default

    Sounds like it could be a Wine problem. Are you using the latest build?

  3. #3
    Join Date
    Jan 2008
    Posts
    7

    Default

    Quote Originally Posted by Porter View Post
    Sounds like it could be a Wine problem. Are you using the latest build?
    I don't think so (and for the record, yes, I am using Wine 0.9.61). However, I tested it with a native linux game as well (http://gaming.gwos.org/doku.php/game...es_of_the_gods)

    I get the same error in Xorg.0.log.
    Code:
    Warning: LookupDrawable()/SecurityLookupDrawable() are deprecated.  Please convert your driver/module to use dixLookupDrawable().
    even though there is no corruption associated with this game, just this error message.


    This just started happening when I updated from Xubuntu 7.10 to Xubuntu 8.04. Maybe it's because of the move from Xorg 7.2 to Xorg 7.3?

  4. #4
    Join Date
    Jan 2008
    Posts
    7

    Default

    At least I'm not the only one with this problem. I just noticed these posts on the ubuntu forums.

    Post 1552 onwards.
    Sample screenshot. (added it to first post as well)
    Last edited by Dreamlocked; 05-09-2008 at 07:07 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •