Page 2 of 10 FirstFirst 1234 ... LastLast
Results 11 to 20 of 95

Thread: RS480/RS690 OSS Compiz Achieved

  1. #11
    Join Date
    Jan 2008
    Posts
    139

    Default

    Thanks! I'm going to try that!

  2. #12
    Join Date
    May 2008
    Posts
    8

    Default

    I've installed libdrm, x11proto-dri2 from
    https://edge.launchpad.net/~xorg-edgers/+archive
    And the ati driver from
    https://launchpad.net/~tormodvolden/+archive
    And mesa from
    https://edge.launchpad.net/~stikonas/+archive

    Now EXA gives fantastic performance, but I still get "Fatal: No GLXFBConfig for default depth, this isn't going to work." when trying to start compiz.

    What else am I missing?

  3. #13
    Join Date
    Jun 2007
    Posts
    406

    Default

    Quote Originally Posted by zombiepig View Post
    I've installed libdrm, x11proto-dri2 from
    https://edge.launchpad.net/~xorg-edgers/+archive
    And the ati driver from
    https://launchpad.net/~tormodvolden/+archive
    And mesa from
    https://edge.launchpad.net/~stikonas/+archive

    Now EXA gives fantastic performance, but I still get "Fatal: No GLXFBConfig for default depth, this isn't going to work." when trying to start compiz.

    What else am I missing?
    what's your xorg.conf?! do you use ati framebuffer?! are you using textured video?!

  4. #14
    Join Date
    Oct 2007
    Location
    Lithuania
    Posts
    35

    Default

    Quote Originally Posted by zombiepig View Post
    I've installed libdrm, x11proto-dri2 from
    https://edge.launchpad.net/~xorg-edgers/+archive
    And the ati driver from
    https://launchpad.net/~tormodvolden/+archive
    And mesa from
    https://edge.launchpad.net/~stikonas/+archive

    Now EXA gives fantastic performance, but I still get "Fatal: No GLXFBConfig for default depth, this isn't going to work." when trying to start compiz.

    What else am I missing?
    You may try also try mesa git from PPA/~xorg-edgers repository, I have only provided as small as possible changes to stable mesa in my PPA/stikonas so that possibility of breaking smth will be much smaller.

  5. #15
    Join Date
    Jun 2007
    Posts
    406

    Default

    i was forgetting:

    did you use the following variable

    Code:
    LIBGL_ALWAYS_INDIRECT=1
    and enabled Dri in xorg.conf?! if you didn't maybe, it's quite the chance that dri isn't enabled, but disabled by default. so you wouldn't be able to run compiz.
    the above variable forces indirect rendering since for the moment it's the only one providing glx_ex_texture_from_pixmap necessary for copiz to run.
    also you need to run compiz with

    Code:
    compiz --replace ccp
    and then use emerald with

    Code:
    emerald --replace
    since kwindecorator doesn't work well (at least for me).

  6. #16
    Join Date
    May 2008
    Posts
    8

    Default

    Quote Originally Posted by givemesugarr
    and enabled Dri in xorg.conf?! if you didn't maybe, it's quite the chance that dri isn't enabled, but disabled by default. so you wouldn't be able to run compiz.
    That's what I was missing - when I added it, compiz started perfectly. This is really fantastic

  7. #17
    Join Date
    Jun 2007
    Posts
    406

    Default

    Quote Originally Posted by zombiepig View Post
    That's what I was missing - when I added it, compiz started perfectly. This is really fantastic
    and is stable also in video playback and fast, even when going with 500+ mbs of ram occupied in compiling and the processor at 100% load. i'm really impressed how well compiz works on the radeon driver. the devs have really done a real good job.

    ps. with dri2 and direct rendering this should be even more faster and good.

  8. #18
    Join Date
    May 2008
    Posts
    7

    Default Slow scrolling

    Hi,

    I followed the instructions, i.e.

    I have also enabled DRI in xorg.conf and checked the X log file and everything looks fine. EXA is activated, along with DRI and PageFlipping.

    I managed to start compiz by setting LIBGL_ALWAYS_INDIRECT to 1 and modifying the script to skip check of ati/radeon driver on a laptop.

    Almost everything works fine. Performance is very good overall. The issue I have is that scrolling a window and moving a window around is very slow (I don't have the wobbling effect activated).

    Any idea? I am running Hardy with an XPRESS 200M (5955) on a HP dv5000 laptop.

  9. #19
    Join Date
    May 2008
    Posts
    8

    Default

    vtence - that sounds like the same steps I took. Maybe try making the changes to xorg.conf that are listed here https://wiki.ubuntu.com/RS485 . I noticed a small performance boost after following those steps.

  10. #20
    Join Date
    May 2008
    Posts
    7

    Default No difference

    zombiepig, thx for your help.

    Unfortunatly, I still cannot make scrolling perf acceptable. Moving windows is really slow as well.

    My xorg.conf looks like this:

    Code:
    Section "Device"
            Identifier      "Configured Video Device"
            Driver          "radeon"
            Option          "AccelMethod" "EXA"
            Option          "EnablePageFlip" "on"
            Option          "DRI"   "true"
            Option          "TexturedVideo" "on"
            Option          "GARTSize" "64"
    EndSection
    
    Section "DRI"
            Mode    0666
    EndSection
    
    Section "Extensions"
            Option "Composite" "Enable"
    EndSection
    I tried without the TexturedVideo option and it does not seem to make any difference.

    IIUC it should not be necessary to specify the Composite option, shouldn't it be on by default in Hardy? What's the use of DRI Mode 0666?

    I'm not sure what else to try. When I run glxinfo, I get:

    Code:
    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
    but the X log file says DRI is activated:

    Code:
    (II) RADEON(0): Direct rendering experimental on RS400/Xpress 200 enabled

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •