Results 1 to 3 of 3

Thread: Help installing ATI drivers

  1. #1
    Join Date
    May 2008
    Posts
    2

    Default Help installing ATI drivers

    I'm trying to install ATI driver 8.476 on my Kubuntu Hardy installation and I'm not having much luck. I'm not able to create the deb files that I need to install. Here's what I get when I type:

    Code:
    sudo sh ati-driver-installer-8-4-x86.x86_64.run --buildpkg Ubuntu/hardy
    Code:
    ==================================================
     ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Ubuntu/hardy
    Package build failed!
    Package build utility output:
    dpkg-buildpackage: set CPPFLAGS to default value:
    dpkg-buildpackage: set CFLAGS to default value: -g -O2
    dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
    dpkg-buildpackage: set FFLAGS to default value: -g -O2
    dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
    dpkg-buildpackage: source package fglrx-installer
    dpkg-buildpackage: source version 2:8.476-0ubuntu1
    dpkg-buildpackage: source changed by ATI Technologies Inc. <http://ati.amd.com/support/d
     debian/rules build
    dpkg-buildpackage: host architecture amd64
    echo "Using architecture: amd64"
    Using architecture: amd64
    for i in preinst postinst postrm shlibs atieventsd.init ; do \
              if [ -f /tmp/fglrx.X19458/debian/driver.$i ]; then \
                sed -e "s/#PKGNAME#/xorg-driver-fglrx/" \
                    -e "s/#DISTRO#/hardy/" /tmp/fglrx.X19458/debian/driver.$i > \
                  /tmp/fglrx.X19458/debian/xorg-driver-fglrx.$i; \
              fi; \
            done
    if [ -f /tmp/fglrx.X19458/debian/10fglrx.template ]; then \
              sed -e "s|#XMODDIR#|usr/lib|" -e "s|#XMODDIR32#|usr/lib32|" \
                /tmp/fglrx.X19458/debian/10fglrx.template > /tmp/fglrx.X19458/debian/10fglrx
            fi
    if [ -f /tmp/fglrx.X19458/debian/fglrx.default ]; then \
              mv /tmp/fglrx.X19458/debian/fglrx.default /tmp/fglrx.X19458/debian/fglrx; \
            fi
    dh_testdir
    dh_testdir
    # move licenses away from binary dir
    if [ ! -d usr/share/doc/fglrx ]; then \
                    mkdir -p usr/share/doc/fglrx; \
                    mv usr/X11R6/bin/LICENSE.* usr/share/doc/fglrx; \
            fi
    # set executable on user apps
    find usr/X11R6/bin -type f | xargs chmod a+x
    # remove exec bit from files that don't deserve it
    find usr/X11R6/include \
                    usr/X11R6/lib \
                    usr/X11R6/lib64 \
                    usr/share usr/src     -type f | xargs chmod -x
    find lib -not -name "*.sh" -type f | xargs chmod -x
    find lib      -name "*.sh" -type f | xargs chmod +x
    # remove exec bit from 64-bit libs too
    find usr/X11R6/lib64       -type f | xargs chmod -x
    dh_testdir
     debian/rules binary
    echo "Using architecture: amd64"
    Using architecture: amd64
    for i in preinst postinst postrm shlibs atieventsd.init ; do \
              if [ -f /tmp/fglrx.X19458/debian/driver.$i ]; then \
                sed -e "s/#PKGNAME#/xorg-driver-fglrx/" \
                    -e "s/#DISTRO#/hardy/" /tmp/fglrx.X19458/debian/driver.$i > \
                  /tmp/fglrx.X19458/debian/xorg-driver-fglrx.$i; \
              fi; \
            done
    if [ -f /tmp/fglrx.X19458/debian/10fglrx.template ]; then \
              sed -e "s|#XMODDIR#|usr/lib|" -e "s|#XMODDIR32#|usr/lib32|" \
                /tmp/fglrx.X19458/debian/10fglrx.template > /tmp/fglrx.X19458/debian/10fglrx
            fi
    if [ -f /tmp/fglrx.X19458/debian/fglrx.default ]; then \
              mv /tmp/fglrx.X19458/debian/fglrx.default /tmp/fglrx.X19458/debian/fglrx; \
            fi
    dh_testdir
    dh_testdir
    # move licenses away from binary dir
    if [ ! -d usr/share/doc/fglrx ]; then \
                    mkdir -p usr/share/doc/fglrx; \
                    mv usr/X11R6/bin/LICENSE.* usr/share/doc/fglrx; \
            fi
    # set executable on user apps
    find usr/X11R6/bin -type f | xargs chmod a+x
    # remove exec bit from files that don't deserve it
    find usr/X11R6/include \
                    usr/X11R6/lib \
                    usr/X11R6/lib64 \
                    usr/share usr/src     -type f | xargs chmod -x
    find lib -not -name "*.sh" -type f | xargs chmod -x
    find lib      -name "*.sh" -type f | xargs chmod +x
    # remove exec bit from 64-bit libs too
    find usr/X11R6/lib64       -type f | xargs chmod -x
    dh_testdir
    dh_testdir
    dh_testroot
    dh_clean -k
    dh_testdir
    dh_testroot
    dh_clean -k
    dh_installdirs
    # Create the directories to install into
    dh_installdirs -pxorg-driver-fglrx \
                    usr/lib \
                    usr/sbin \
                    usr/lib \
                    usr/lib/xorg/modules \
                    usr/lib/xorg/modules/drivers \
                    usr/lib/xorg/modules/linux \
                    etc/acpi \
                    etc/acpi/events \
                    etc/default \
                    etc/X11/Xsession.d \
    
    # the amd64 package includes 32bit compatibility libraries
    dh_installdirs -pxorg-driver-fglrx \
                    usr/lib32 \
                    usr/lib32
    dh_installdirs -A -pxorg-driver-fglrx \
                    usr/bin \
                    usr/sbin \
                    usr/share \
                    usr/share/applnk \
                    usr/share/gnome \
                    usr/share/gnome/apps \
                    usr/share/icons \
                    usr/share/pixmaps
    dh_installdirs -pxorg-driver-fglrx-dev \
                    usr/include \
                    usr/lib
    dh_installdirs -pfglrx-kernel-source \
                    usr/src/fglrx-8.476
    dh_install
    # Driver package
    /sbin/ldconfig -n usr/X11R6/lib/
    dh_install -pxorg-driver-fglrx "usr/X11R6/bin/fgl*"      "usr/bin"
    dh_install -pxorg-driver-fglrx "usr/X11R6/bin/aticonfig" "usr/bin"
    dh_install -pxorg-driver-fglrx "usr/sbin/atieventsd"     "usr/sbin"
    dh_installman -pxorg-driver-fglrx "usr/share/man/man8/atieventsd.8"
    # amd64 needs some library redirection
    dh_install -pxorg-driver-fglrx "usr/X11R6/lib64/*.so*"           "usr/lib"
    dh_install -pxorg-driver-fglrx "usr/X11R6/lib64/modules/dri"     "usr/lib"
    dh_install -pxorg-driver-fglrx "usr/X11R6/lib64/modules/linux"   "usr/lib/xorg/modules"
    dh_install -pxorg-driver-fglrx "usr/X11R6/lib64/modules/drivers" "usr/lib/xorg/modules"
    dh_install -pxorg-driver-fglrx "usr/X11R6/lib64/modules/*.so"    "usr/lib/xorg/modules"
    dh_install -pxorg-driver-fglrx "usr/X11R6/lib64/modules/*.a"     "usr/lib/xorg/modules"
    dh_install -pxorg-driver-fglrx "usr/X11R6/lib/*.so*"           "usr/lib32"
    dh_install -pxorg-driver-fglrx "usr/X11R6/lib/modules/dri"     "usr/lib32"
    dh_install -pxorg-driver-fglrx "etc/ati"                   "etc"
    dh_install -pxorg-driver-fglrx "debian/10fglrx"            "etc/X11/Xsession.d"
    dh_install -pxorg-driver-fglrx "debian/fglrx-powermode.sh" "etc/acpi"
    dh_install -pxorg-driver-fglrx "debian/fglrx-*-aticonfig"  "etc/acpi/events"
    dh_install -pxorg-driver-fglrx "debian/fglrx"              "etc/default"
    dh_installinit -pxorg-driver-fglrx --name="atieventsd"
    # Driver dev package
    dh_install -pxorg-driver-fglrx-dev "usr/X11R6/lib64/*.a" "usr/lib"
    dh_install -pxorg-driver-fglrx-dev "usr/X11R6/include/*" "usr/include"
    dh_install -pxorg-driver-fglrx-dev "usr/include/*"       "usr/include"
    #Create dkms.conf
    echo "PACKAGE_NAME=\"fglrx\"" > debian/dkms.conf
    echo "PACKAGE_VERSION=\"8.476\"" >> debian/dkms.conf
    echo "CLEAN=\"rm -f *.*o\"" >> debian/dkms.conf
    echo "BUILT_MODULE_NAME[0]=\"fglrx\"" >> debian/dkms.conf
    echo "MAKE[0]=\"pushd \${dkms_tree}/fglrx/8.476/build; sh make.sh --nohints; popd\"
    echo "DEST_MODULE_LOCATION[0]=\"/kernel/drivers/char/drm\"" >> debian/dkm
    echo "AUTOINSTALL=\"yes\"" >> debian/dkms.conf
    # Kernel source package
    dh_install -pfglrx-kernel-source \
                    lib/modules/fglrx/build_mod/*.c            \
                    lib/modules/fglrx/build_mod/*.h            \
                    lib/modules/fglrx/build_mod/*.sh           \
                    lib/modules/fglrx/build_mod/lib*           \
                    lib/modules/fglrx/build_mod/2.6.x/Makefile \
                    debian/dkms.conf                           \
                    usr/src/fglrx-8.476
    # control panel package
    dh_install -A -pfglrx-amdcccle "usr/X11R6/bin/amdcccle"
    dh_install -A -pfglrx-amdcccle "usr/share/icons/*.xpm"
    dh_install -A -pfglrx-amdcccle "usr/share/icons/*.xpm"
    dh_install -A -pfglrx-amdcccle "debian/amdcccle.desktop"
    dh_install -A -pfglrx-amdcccle "debian/amdcccle.kdelnk"
    dh_install -A -pfglrx-amdcccle "usr/share/ati"
    dh_desktop    -pfglrx-amdcccle
    # start the install
    dh_installdocs
    dh_installdocs -pxorg-driver-fglrx usr/share/doc/fglrx/*
    #dh_installchangelogs
    dh_link
    dh_strip
    dh_compress
    dh_installdeb
    dh_makeshlibs
    dh_shlibdeps
    dpkg-shlibdeps: warning: symbol XauFileName used by debian/xorg-driver-fg               s.
    dpkg-shlibdeps: warning: debian/xorg-driver-fglrx/usr/sbin/atieventsd sho               f its symbols).
    dpkg-shlibdeps: failure: couldn't find library libfglrx_gamma.so.1 needed               s RPATH is '').
    Note: libraries are not searched in other binary packages that do not hav
    To help dpkg-shlibdeps find private libraries, you might need to set LD_L
    dh_shlibdeps: command returned error code 512
    make: *** [binary] Error 1
    dpkg-buildpackage: failure: debian/rules binary gave error exit status 2
    Removing temporary directory: fglrx-install.l19317
    The kernel that I'm using is 2.6.25.

    Thanks for any help.

  2. #2
    Join Date
    Mar 2008
    Location
    Osnabrück, Germany
    Posts
    79

    Default

    2.6.25 on Ubuntu? No offense, but I can't understand why people who want to "live" on the bleeding etch use ubuntu.

    Nevertheless, why do you install it on this way? The 8.4 driver is in the rep.

    Code:
    sudo apt-get update	
    sudo apt-get install linux-restricted-modules-generic restricted-manager
    sudo apt-get install xorg-driver-fglrx
    sudo depmod -a

  3. #3
    Join Date
    May 2008
    Posts
    2

    Default

    I didn't think installing it from the rep would work because I'm not using the standard 2.6.24 kernel that comes with Hardy. So you believe that it would work ok doing it this way?

    Quote Originally Posted by izual View Post
    2.6.25 on Ubuntu? No offense, but I can't understand why people who want to "live" on the bleeding etch use ubuntu.

    Nevertheless, why do you install it on this way? The 8.4 driver is in the rep.

    Code:
    sudo apt-get update	
    sudo apt-get install linux-restricted-modules-generic restricted-manager
    sudo apt-get install xorg-driver-fglrx
    sudo depmod -a

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •