Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: EDID and randr1.2 with radeon

  1. #1
    Join Date
    Jul 2007
    Posts
    403

    Default EDID and randr1.2 with radeon

    Using the radeon driver, it apparently detects my monitor's supported refresh rates with EDID (I think.) At any rate, randr doesn't let me set my refresh rate higher than 85hz, even though my monitor supports 100hz. I could try and add a modline, but I'd like to do this through randr. Is there any way to do that?

  2. #2
    Join Date
    Dec 2007
    Posts
    2,328

    Default

    Quote Originally Posted by TechMage89 View Post
    Using the radeon driver, it apparently detects my monitor's supported refresh rates with EDID (I think.) At any rate, randr doesn't let me set my refresh rate higher than 85hz, even though my monitor supports 100hz. I could try and add a modline, but I'd like to do this through randr. Is there any way to do that?
    you can add arbitrary modelines with xrandr:
    xrandr --newmode <modeline>
    xrandr --addmode <output> <modename>
    xrandr --output <output> --mode <modename>

    for example to add 1024x768@100Hz to the VGA port:

    xrandr --newmode "1024x768_100.00" 112.25 1024 1096 1200 1376 768 771 775 816 -hsync +vsync
    xrandr --addmode VGA-0 "1024x768_100.00"
    xrandr --output VGA-0 --mode "1024x768_100.00"

    see xrandr --help for more.

  3. #3
    Join Date
    Apr 2007
    Location
    Bulgaria
    Posts
    269

    Default

    When I try to do something similar and I get to

    :~$ xrandr --addmode VGA_1 "1440x900_75.00"
    X Error of failed request: BadMatch (invalid parameter attributes)
    Major opcode of failed request: 155 (RANDR)
    Minor opcode of failed request: 18 ()
    Serial number of failed request: 16
    Current serial number in output stream: 17

    What does it mean?

  4. #4
    Join Date
    Dec 2007
    Posts
    2,328

    Default

    Quote Originally Posted by sundown View Post
    When I try to do something similar and I get to

    :~$ xrandr --addmode VGA_1 "1440x900_75.00"
    X Error of failed request: BadMatch (invalid parameter attributes)
    Major opcode of failed request: 155 (RANDR)
    Minor opcode of failed request: 18 ()
    Serial number of failed request: 16
    Current serial number in output stream: 17

    What does it mean?
    Did you define "1440x900_75.00" using --newmode?

  5. #5
    Join Date
    Apr 2007
    Location
    Bulgaria
    Posts
    269

    Default

    Quote Originally Posted by agd5f View Post
    Did you define "1440x900_75.00" using --newmode?
    Sure, I did: xrandr --newmode "1440x900_75.00" 136.49 1440 1536 1688 1936 900 901 904 940 -HSync +Vsync

    Then, I ran the xrandr command to see what it says and it does say at the bottom of all the information provided:
    Code:
    1440x900_75.00 (0x63)  136.5MHz
            h: width  1440 start 1536 end 1688 total 1936 skew    0 clock   70.5KHz
            v: height  900 start  901 end  904 total  940           clock   75.0Hz
    Previously that would not appear prior to running the --newmode command, meaning it did something, but than fails with the --addmode

  6. #6
    Join Date
    Dec 2007
    Posts
    2,328

    Default

    Quote Originally Posted by sundown View Post
    Sure, I did: xrandr --newmode "1440x900_75.00" 136.49 1440 1536 1688 1936 900 901 904 940 -HSync +Vsync

    Then, I ran the xrandr command to see what it says and it does say at the bottom of all the information provided:
    Code:
    1440x900_75.00 (0x63)  136.5MHz
            h: width  1440 start 1536 end 1688 total 1936 skew    0 clock   70.5KHz
            v: height  900 start  901 end  904 total  940           clock   75.0Hz
    Previously that would not appear prior to running the --newmode command, meaning it did something, but than fails with the --addmode
    Are you sure output name is VGA_1? On radeon it's VGA-0 or VGA-1 depending on how many VGA ports you have.

  7. #7
    Join Date
    Apr 2007
    Location
    Bulgaria
    Posts
    269

    Default

    Oh sorry, I was doing this on the wrong driver

    OMG it worked... I can't believe I'm running in 75hz I've been dreaming for this for soooo long Thanks a lot.
    How can I memorize this for the system?
    Last edited by sundown; 05-17-2008 at 03:20 PM.

  8. #8
    Join Date
    Dec 2007
    Posts
    2,328

    Default

    Quote Originally Posted by sundown View Post
    Oh sorry, I was doing this on the wrong driver

    OMG it worked... I can't believe I'm running in 75hz I've been dreaming for this for soooo long Thanks a lot.
    How can I memorize this for the system?
    Add a monitor section and associate it with the output in question then add these to your monitor section:
    Modeline "1440x900_75.00" 136.49 1440 1536 1688 1936 900 901 904 940 -HSync +Vsync
    Option "PerferredMode" "1440x900_75.00"

    See this page for more:
    http://www.intellinuxgraphics.org/dualhead.html

  9. #9
    Join Date
    Apr 2007
    Location
    Bulgaria
    Posts
    269

    Default

    Thanks.

    I found this easier for understanding http://wiki.debian.org/XStrikeForce/HowToRandR12

  10. #10
    Join Date
    Jul 2007
    Posts
    403

    Default

    how do I make this change persistant? The mode doesn't keep over a reboot, and I always want to be at 100hz.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •