Results 1 to 7 of 7

Thread: fglrx, xgl, compiz.

  1. #1
    Join Date
    Nov 2006
    Posts
    8

    Default fglrx, xgl, compiz.

    I am still trying to use compiz/beryl with my ATI 9200 card, fgrlx driver 8.28.8 and xgl, but it is not easy.
    I am starting xgl with
    /usr/bin/startxgl.sh:
    Xgl :1 -fullscreen -ac -accel xvbuffer -fp /usr/share/fonts/X11/misc,/usr/X11R6/lib/X11/fonts/misc -accel glxbuffer &
    DISPLAY=:1
    sleep 3
    compiz --replace gconf cube rotate scale fade minimize zoom place move wobbly &
    sleep 3
    gtk-window-decorator --replace &
    exec gnome-session

    and xgl is starting, and a gnome session is starting. But when I try to start beryl I get:
    XGL Present
    beryl: GLX_EXT_texture_from_pixmap is missing
    beryl: Failed to manage screen: 0
    beryl: No manageable screens found on display :1.0
    I have tried to add these lines in my startxgl.sh:
    LD_LIBRARY_PATH=/usr/lib/libGL.so.1.2
    export LD_LIBRARY_PATH
    but of no use.

    Do I have to drop xgl and go for AIGXL?

    Helge

  2. #2

    Default

    you can drop XGL and go for AIGLX. With the Radeon 9200 you can use the open-source drivers. Should work in no time.

  3. #3
    Join Date
    Nov 2006
    Posts
    8

    Default

    When trying to start compiz or Beryl everything is freezing totally, and I have to restart my PC with the button.

    cat /var/log/Xorg.0.log | grep EE
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    (EE) AIGLX error: dlopen of /usr/lib/dri/r200_dri.so failed (/usr/lib/dri/r200_dri.so: cannot open shared object file: No such file or directory)
    (EE) AIGLX: reverting to software rendering
    (EE) Error loading keymap /var/lib/xkb/server-0.xkm

    Am I using the wrong driver (ati)?

    Section "Device"
    Identifier "ATI Technologies, Inc. RV280 [Radeon 9200 SE]"
    Driver "ati"
    BusID "PCI:1:0:0"
    Option "XAANoOffscreenPixmaps" "true"
    Option "DRI" "true"
    EndSection

  4. #4

    Default

    Driver should be radeon

  5. #5
    Join Date
    Nov 2006
    Posts
    8

    Default

    I have uninstalled the fglrx driver; using ati and have changed to "radeon" in xorg.conf.
    But I still cannot start beryl properly, but gets a white screen after some second.
    cat /var/log/Xorg.0.log | grep EE
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    (EE) AIGLX error: dlopen of /usr/lib/dri/r200_dri.so failed (/usr/lib/dri/r200_dri.so: cannot open shared object file: No such file or directory)
    (EE) AIGLX: reverting to software rendering

    I find here http://www.mail-archive.com/ubuntu-b...msg156182.html
    r200_dri is the correct driver. The radeon one is for older cards.

    Is there a special radeon driver, and where can I get it?
    I have no r200_dri.so; locate r200_dri.so gives nothing.

  6. #6

    Default

    The Radeon driver may have gotten messed up from the fglrx drivers. Try reinstalling the Fedora RPMs for xorg.

  7. #7
    Join Date
    Nov 2006
    Posts
    8

    Default

    Thank you for help, but I found the r200_dr.so in the libgli-mesa-dri package - at last.
    I had some problems with this package and the libgli-mesa-glx package; there is a conflict between liggli-mesa-glx and libgl1, libgl1-mesa-dri (<< 6.4.0), but I have libgli-mesa-dri 6.5.1+cvs20060824, and though it seems not possible to install both. At least the last time I tried.
    I shall try first without this libgli-mesa-glx.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •