Page 11 of 18 FirstFirst ... 910111213 ... LastLast
Results 101 to 110 of 174

Thread: Installing latest Open Source ATI drivers under Ubuntu 8.04

  1. #101
    Join Date
    Jun 2008
    Posts
    61

    Default

    AIGLX (and therefore Compiz) is not supported when using mesa 7.1 packages unless you also upgrade your xserver
    , KWin4's built-in effects aren't going to work as well, right?
    Last edited by mityukov; 08-04-2008 at 10:40 AM.

  2. #102
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,578

    Default

    AFAIK if you don't use the new X server then AIGLX doesn't work with the latest Mesa code (and you need recent Mesa code to get full 5xx 3d support).

    I'm not completely sure that KWin4 uses AIGLX but I think it does... so probably won't work without new X server.

  3. #103
    Join Date
    Jun 2008
    Posts
    61

    Default

    Quote Originally Posted by bridgman View Post
    AFAIK if you don't use the new X server then AIGLX doesn't work with the latest Mesa code (and you need recent Mesa code to get full 5xx 3d support).

    I'm not completely sure that KWin4 uses AIGLX but I think it does... so probably won't work without new X server.
    If I remember correctly (I'm not at home), there are tree options:
    - OpenGL (texture_from_pixmap)
    - PO Buffer
    - Backbuffer

    I may be wrong, though :-)

    Is AIGLX-support required for each of these "renderers"? And is there a one, supported by OpSc radeon?

  4. #104
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,578

    Default

    AIGLX support works fine on 5xx with both radeon (aka -ati) and radeonhd if you have relatively recent DDX, DRM, Mesa and X server. Building a recent X server is a bit of a pain so the question as I understood it was "what do I get if I stay with an old X server ?".

    It's the new Mesa code which requires the new X server (something related to DRI2 IIRC), not radeon or radeonhd.

  5. #105
    Join Date
    Aug 2008
    Posts
    19

    Default

    I've successfully install the drivers, drm modules and libdrm/mesa packages which has enabled 3D Acceleration using the Driver "ati" and AccelMethod "EXA" on my x1250
    However this appears to have broken an application I'm using because of some incompatibility between libgl and libstdc++. I've google for all sorts of options and found this bug
    https://bugs.launchpad.net/ubuntu/+s...sa/+bug/259219

    It mentions compiling without --enable-glx-tls. are the sources available for the packages provided in xorg-edgers and how would I go about recompiling/repacking the libgl-mesa-dri package

  6. #106
    Join Date
    May 2008
    Posts
    343

    Default

    Quote Originally Posted by ovoskeuiks View Post
    I've successfully install the drivers, drm modules and libdrm/mesa packages which has enabled 3D Acceleration using the Driver "ati" and AccelMethod "EXA" on my x1250
    However this appears to have broken an application I'm using because of some incompatibility between libgl and libstdc++. I've google for all sorts of options and found this bug
    https://bugs.launchpad.net/ubuntu/+s...sa/+bug/259219

    It mentions compiling without --enable-glx-tls. are the sources available for the packages provided in xorg-edgers and how would I go about recompiling/repacking the libgl-mesa-dri package
    IIRC --enable-glx-tls was needed for some reason but I am not sure. Yes, the sources are in the PPA of course. There's a mini-HOWTO on the XorgOnTheEdge page for how to recompile packages yourself.

  7. #107
    Join Date
    Aug 2008
    Posts
    19

    Default

    Quote Originally Posted by tormod View Post
    IIRC --enable-glx-tls was needed for some reason but I am not sure. Yes, the sources are in the PPA of course. There's a mini-HOWTO on the XorgOnTheEdge page for how to recompile packages yourself.
    Thanks I've successfully compiled the driver a few times and no luck with getting my software working, could someone point me in a direction where I could offer useful feedback on this? It doesn't appear to be an issue with the software (libavg) as it works fine on nvidia and intel based boards so I'm assuming it's to do with the ati dri implementation

  8. #108
    Join Date
    May 2008
    Posts
    343

    Default

    Quote Originally Posted by ovoskeuiks View Post
    Thanks I've successfully compiled the driver a few times and no luck with getting my software working, could someone point me in a direction where I could offer useful feedback on this? It doesn't appear to be an issue with the software (libavg) as it works fine on nvidia and intel based boards so I'm assuming it's to do with the ati dri implementation
    If you can confirm this bug in Ubuntu (Intrepid) it should be dealt with. You may also ask on #ubuntu-ch (I guess tjaalton will know).

  9. #109
    Join Date
    Sep 2008
    Posts
    1

    Default

    hi oibaf

    i am a complete newbie, my first ubuntu install,my first problem ,my first use of the terminal and a complete success thanks to the clarity of your post.

    many thanks

  10. #110

    Default

    tormod, can you update your -ati package to current git version (possibly on both hardy/intrepid)? I'd like to test the latest upstream fixes for dithering, that should better fix LP bug #264535.

    Also, this appears to be no more needed on intrepid:
    Code:
      * Drop depends on xserver-xorg-video-r128 and xserver-xorg-video-
        mach64 (and their -dbg packages) since they don't exist in Ubuntu
        yet
    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •