Page 2 of 18 FirstFirst 123412 ... LastLast
Results 11 to 20 of 174

Thread: Installing latest Open Source ATI drivers under Ubuntu 8.04

  1. #11
    Join Date
    Mar 2008
    Location
    Germany
    Posts
    11

    Default

    Quote Originally Posted by oibaf View Post
    Section 0 of my first post: 0 - Introduction and status
    oh...

    i changed to 'radeon' and it works now! glxinfo even shows: OpenGL version string: 1.3 Mesa 7.1.
    Though i find it odd, that when i change back to radeonhd, glxinfo shows the old mesa version.

    Anyway, thanks for the help!
    tzu

  2. #12
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,566

    Default

    I think that makes sense. DRI support for radeonhd is in a side branch, not master, so you're probably falling back to software rendering with radeonhd right now.

    If you *really* want to live dangerously, you could try Matthias's radeonhd repo with DRI support along with drm master and mesa r500-support.

    I think there's a Phoronix article with details.

  3. #13
    Join Date
    Jul 2007
    Posts
    13

    Default

    I tried the above post in #1 for a R420 card just for the helluva it on ubuntu 8.04.

    It semi-works, im getting 5000+ fps in glxgears, and that openarena bencmark is gibing 100+ fps, but aiglx now seems to be screwed?

    (EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/r300_dri.so: undefined symbol: __driCreateNewScreen_20050727)
    (EE) AIGLX: reverting to software rendering

    glxinfo says:
    OpenGL vendor string: DRI R300 Project
    OpenGL renderer string: Mesa DRI R300 20060815 AGP 8x x86/MMX+/3DNow!+/SSE2 TCL
    OpenGL version string: 1.3 Mesa 7.1

    Im guessing my r300_dri.so is wrong?

    ls -al /usr/lib/dri/r300_dri.so
    -rw-r--r-- 1 root root 2233076 2008-05-25 16:38 /usr/lib/dri/r300_dri.so

  4. #14

    Default

    Quote Originally Posted by grazzt View Post
    I tried the above post in #1 for a R420 card just for the helluva it on ubuntu 8.04.

    It semi-works, im getting 5000+ fps in glxgears, and that openarena bencmark is gibing 100+ fps, but aiglx now seems to be screwed?

    (EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/r300_dri.so: undefined symbol: __driCreateNewScreen_20050727)
    (EE) AIGLX: reverting to software rendering

    glxinfo says:
    OpenGL vendor string: DRI R300 Project
    OpenGL renderer string: Mesa DRI R300 20060815 AGP 8x x86/MMX+/3DNow!+/SSE2 TCL
    OpenGL version string: 1.3 Mesa 7.1

    Im guessing my r300_dri.so is wrong?

    ls -al /usr/lib/dri/r300_dri.so
    -rw-r--r-- 1 root root 2233076 2008-05-25 16:38 /usr/lib/dri/r300_dri.so
    Hi, this is a know limitation. To "fix" this you should upgrade your xserver to a git version. Packages can be found here (WARNING: THESE PACKAGES APPEARS TO BE VERY EXPERIMENTAL AND MAY BROKE YOUR SYSTEM):
    https://edge.launchpad.net/~xorg-edgers/+archive

    See also the post of airlied:
    http://airlied.livejournal.com/60149.html

    I'll add this info on first post.

  5. #15
    Join Date
    Jul 2007
    Posts
    13

    Default

    Thanks for the quick response.

    And youre right, it may break your system, it did with me. Well, compiz+cube running glxgears doesnt work well together.

  6. #16
    Join Date
    Nov 2007
    Posts
    25

    Default

    I did the update... to my kubuntu hardy.
    One thing i noticed is glxgears results: 365FPS.
    It dropped to half what it was. Is everything as it should be or am i missing something???
    I'm running on Ati 2400 w/ 256mb.
    Last edited by mal13; 05-26-2008 at 01:36 PM. Reason: more info

  7. #17
    Join Date
    May 2008
    Posts
    5

    Default Compiz and upgrades?

    Thanks very much for these easy to follow instructions.

    I will report for the search engines that my Thinkpad T60p with
    the FireGL 5250 graphic worked by following the instructions. I used
    the "ati" driver and 3D works (glxgears is about 2300FPS).
    In Gutsy I was seeing about 4000FPS with the ATI fglrx driver but
    could not get fglrx to install with Hardy.

    Two questions about the above:

    1) I see today that my update manager wants to upgrade my kernel.
    What steps above do I need to re-do if my kernel is upgraded?

    2) Compiz is not working. Is it possible to get compiz working with
    this "ati" driver? (In Gutsy and with fglrx I had xserver-xgl installed).


    Oh, BTW -- why is it important to disable the sources above after using them? Will it bring in other packages that are not desirable?

    Thanks,

  8. #18

    Default

    Quote Originally Posted by mal13 View Post
    I did the update... to my kubuntu hardy.
    One thing i noticed is glxgears results: 365FPS.
    It dropped to half what it was. Is everything as it should be or am i missing something???
    I'm running on Ati 2400 w/ 256mb.
    3D supports appears to be supported for <R600 cards. Your is a RV610/RV630?

    I added this on first post.

    Edit: try
    Code:
    $ glxinfo | grep 'direct rendering'
    Warning, RV530 detected, 3D HAHAHAHAHA!!.
    direct rendering: Yes
    if you get No you are not using accelerated 3D.

    Try using other combinations of Driver (ati or radeonhd) and Option "AccelMethod" (ShadowFB (only for radeonhd), XAA or EXA) in your xorg.conf to see if you get a faster X.
    Last edited by oibaf; 05-27-2008 at 04:46 AM.

  9. #19

    Default

    Quote Originally Posted by freetime View Post
    Thanks very much for these easy to follow instructions.

    I will report for the search engines that my Thinkpad T60p with
    the FireGL 5250 graphic worked by following the instructions. I used
    the "ati" driver and 3D works (glxgears is about 2300FPS).
    In Gutsy I was seeing about 4000FPS with the ATI fglrx driver but
    could not get fglrx to install with Hardy.

    Two questions about the above:

    1) I see today that my update manager wants to upgrade my kernel.
    What steps above do I need to re-do if my kernel is upgraded?
    You should only reinstall the DRM module. (Now added in first post)

    2) Compiz is not working. Is it possible to get compiz working with
    this "ati" driver? (In Gutsy and with fglrx I had xserver-xgl installed).
    See comment 13 and the following two.
    Oh, BTW -- why is it important to disable the sources above after using them? Will it bring in other packages that are not desirable?

    Thanks,
    These two repositories include a lot of other packages: see https://edge.launchpad.net/~xorg-edgers/+archive and
    https://launchpad.net/~tormodvolden/+archive . I would not keep the repositories enabled unless you really need all other packages (note that also an updated experimental xserver is included).
    Last edited by oibaf; 05-27-2008 at 04:40 AM.

  10. #20
    Join Date
    Nov 2007
    Posts
    25

    Default

    Knowtiest how experimental some packages were. I left repos open...
    Result: adept and system logs wouldn't open anymore. Best part was to come: mouse and keyboard stopped working. I couldn't login. After dozen reboots to xp (to search info) finally got my system fixed.
    xserver-xorg was problem.
    Now i'm back on mesa. Forawhile.... i'll get back to radeon. Later.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •