Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Radeon HD 3870 + fglrx + 64 bit linux = crash

  1. #1

    Angry Radeon HD 3870 + fglrx + 64 bit linux = crash FIXED!

    Hi!

    As I mentioned before, i'm trying to run a Radeon HD 3870 with 64bit (amd64) Linux. If i use the fglrx driver and call xinit the system hang with a black screen. This is a hard crash and i can't see any output and no xorg.log will be written to disk. I've tested the fglrx 7.12 and 8.01 on Debian sid and Suse 10.3 with always the same results. The vesa driver works on these systems. Also the radeonhd driver works but corupts the system console. On 32 bit systems the fglrx driver works . The radeon bios is the first released version (compiled on 2007-10-17). The serial port on my worse asus p5k board doesn't work so i can't use a serial console to give more information.

    Can anybody give me a hint?
    Or has anybody a working 64bit/3870/fglrx configuration?
    Last edited by zappbrannigan; 03-03-2008 at 03:13 PM. Reason: changed title

  2. #2
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    You can use netconsole too. Just be sure you use the interface with least shared interrupts.

  3. #3

    Default

    Quote Originally Posted by Kano View Post
    You can use netconsole too. Just be sure you use the interface with least shared interrupts.
    Thank you. I'll try this tomorrow.

  4. #4

    Default

    I got this single line:
    Code:
    mtrr: type mismatch for d0000000,10000000 old: write-back new: write-combining
    Is it possible to redirect the tty output with netconsole?

  5. #5

    Default

    OK, I found a workaround for the system hang. I disabled the "Memory Remap Feature" in the bios. Who is to blame? The fglrx driver or ASUS? The Mainboard is a P5k with bios version 0805. The xorg.log file is too big to post but I saw this line:
    Code:
    (**) fglrx(0): ATI GART size: 256 MB
    I think this is too small since the HD3780 has 512 MB.
    The workaround is not a solution because I lost 768 MB of my memory.

  6. #6

    Default

    Finally, someone with the same problem! I've been searching high and low as to why the fglrx 8.01 (and all other versions) crash my system. I'm running a Gigabyte X38-DS4 motherboard with an HD3870. I don't have a "Memory Remap Feature" in my BIOS, and from the looks of it, I don't think I'd want to use it either.

  7. #7
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    How much system RAM do you guys have ?

  8. #8

    Default

    Quote Originally Posted by bridgman View Post
    How much system RAM do you guys have ?
    4GB of DDR2

  9. #9
    Join Date
    Dec 2007
    Location
    Merida
    Posts
    1,099

    Default

    I have used HD3xxx cards before on 64bit distros (mainly Ubuntu and Suse) with both 7.12 and 8.01 drivers with no serious issues. This was with a X580 board, so maybe it's not the card/drivers but something with your particular MOBO?

  10. #10

    Default

    Well, actually, I had a similar result with 7.12 on an older AMD 939 / Opteron 165 / 2GB RAM system. I had an Nvidia 7950GT, which worked just fine. Who knows. At this point I've given up as I simply don't have the time to play with it. I'll just have to stick with a VM on top of Vista for now. I will however keep track of this thread to see if any solution comes about.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •