Page 5 of 5 FirstFirst ... 345
Results 41 to 46 of 46

Thread: Where is fglrx / catalyst 8.5?

  1. #41
    Join Date
    May 2008
    Posts
    73

    Thumbs down Build fails on Fedora 9 as well

    Generating package: Fedora/F9
    Package build failed!
    Package build utility output:
    error: %changelog entries must start with *
    Building target platforms: i386
    Building for target i386

  2. #42
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    365

    Default

    Okay, so first things first:
    1. I also couldnt start any 3d apps with 8.4 under wine, I always got errors like
    libGL error: drmMap of framebuffer failed (Not enough memory)
    libGL error: reverting to (slow) indirect rendering
    This happens e.g. for warcraft 3, counterstrike, icy tower and also occurs for normal apps (though DX apps get it twice I think)
    2.
    i have tried this driver 8.493 again without watermark (with the howto sed -i ...) and there is a white screen with compiz fusion on my ubuntu hardy 32 Bit.
    The white screen means that you dont have any 3d acceleration. It also occurs for me.
    3. wtf... I just noticed my watermark is gone though I didnt upgrade the driver nor do anything else... this driver confuses me
    4. Apart from that, I didnt yet notice any 2ed accel improvements, maybe because 3D is broken, too (using a V530)
    5. One positive side though:
    Known Issues

    The following section provides a brief description of known issues associated with the latest version of ATI Catalyst™ Linux software suite. These issues include:

    * Desktop corruption may be noticed when dragging the overlay/video when using dual-display mode. Further details can be found in topic number 737-29578
    * Bandwidth corruption may be noticed when setting the desktop resolution to 2048x1536 on systems containing an ATI Radeon HD 3200 series of product. Further details can be found in topic number 737-33499
    * SECAM, NTSC or PAL signal changes when using aticonfig or Catalyst Control Center but does not apply to the TV display output. Further details can be found in topic number 737-34297
    * Running X server without a window manager may result in the X server flashing green for a moment, going black, and the computer becoming unresponsive. Further details can be found in topic number 737-34299
    * Desktop corruption may be noticed when dragging the overlay/video when using dual-display mode. Further details can be found in topic number 737-34298
    * Connecting a CRT display device to a system containing an ATI Mobility Radeon X1600 product may result in the display device flashing multiple times or failing to display an image when attempting to launch the Catalyst Control Center. Further details can be found in topic number 737-34300
    * Corruption may be noticed when connecting a DFP display device to a system running X after setting the TV mode to 1080i. Further details can be found in topic number 737-34301
    * Quake 3 Arena (demo): Segmentation faults may occur when attempting to play the game. Further details can be found in topic number 737-34302
    * Specviewperf: Launching the application may result in the Linux operating system failing to respond. Further details can be found in topic number 737-34282
    * Opening a terminal and running semi-automated DPPT tests via lnxtest.sh may result in the operating system failing to respond. Further details can be found in topic number 737-34283
    * A segmentation fault may occur when running SPECViewperf on systems containing an ATI FireGL V5100 series product and running SUSE 10.3 x86. Further details can be found in topic number 737-34319
    * FGL_GLXGEARS or GLXGEARS: X may fail to respond when launching either of the applications. Further details can be found in topic number 737-34316
    * Maya 2008: Various comparison failures may be noticed. Further details can be found in topic number 737-34277
    * The X Server may fail to reset clearly when AIGLX is enabled. Further details can be found in topic number 737-34317
    * DiscoveryStudio1.7: The print preview and save as functions may fail to work properly. Further details can be found in topic number 737-34278
    * SPEC Viewperf 8.1: A performance drop may be noticed when running the application under Linux. Further details can be found in topic number 737-34279
    * Maya2008: The hardware render buffer may fail to render/display the image. Further details can be found in topic number 737-34280
    * May2008: The hardware render Perl script may display an error message when rendering. Further details can be found in topic number 737-34281
    You see? For the first time (IIRC) they say something about real-world examples for whats not working yet. Now, thats an improvement in my eyes

    Sorry for any typos, Im using a non-native keylayout at the moment

    EDIT: Seems like I have to fizzle a bit more with this new driver, my kernel still loads the old module from 8.4....
    EDIT2: Cant create a fedora8 package neither, same error as quintesse.
    Last edited by NeoBrain; 05-22-2008 at 05:59 AM.

  3. #43
    Join Date
    May 2008
    Posts
    3

    Default

    I have tried with FC 8 x86_64 with vanilla kernel 2.6.25.4 on Thinkpad R60 (ati x1400). I have tried with various option but, with kde3 and qt3, the fonts are corrupted (if I use antialiased font). With this "new" driver I have some "rendom hole" in all kde3 and qt3 apps.
    This problem occurs since the first 8.x driver series. If I remove (only) fglrx module from the kernel the problem goes away!

  4. #44
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    365

    Default

    Okaz I was able to create a Fedora package by Suspending the terminal with CTRL+S and then hacking the file fglrx-install.xxxxxx/packages/Fedora/ATI-fglrx.spec-tmpl:
    1. line 287: insert the line /usr/X11R6/lib/libatiadlxx.so right after @X11_MODULE_DIR@/glesx.so
    2. Remove line 323 (- Add compat-libstdc++ as a required dependency)
    and resume the install with CTRL+Q.

    You have to do the suspending at about
    Uncompressing ATI Proprietary Linux Driver-.493..................... .................................................. ..................
    .................
    (i.e. about 1 thirdth of the dots completed )

    EDIT: the rpm package doesnt seem to recognise that I have compat-libstdc++ installed, so one may also want to remove line 28 (Requires: compat-libstdc++)
    Last edited by NeoBrain; 05-22-2008 at 06:29 AM.

  5. #45
    Join Date
    Jan 2008
    Posts
    294

    Default

    Quote Originally Posted by benwick View Post
    A week *so far* ...

    Every month I get all excited thinking, "maybe this will be the one where I never ever have to reboot to Windows ever again just to watch video!!" They were so close with 8.3 but the jerkiness and weird semi-tearing gave me headaches (especially on a projector). So close, but so far... And 8.4 was just a slap in the face.

    I'd also like it to run under 2.6.25 but I'll settle for 2.6.24 if it works.
    If you set vsync on (quality in amdcccle) and use something like

    mplayer -vo gl:yuv=4:lscale=1

    you shouldn't see any tearing - maybe it depends on the card, but I don't on an X1600pro.

    You can try different yuv/lscale options to suit your cards capabilities and scale type preference, see the manual.

  6. #46
    Join Date
    Jun 2008
    Posts
    1

    Default I have the same problem.

    Quote Originally Posted by quintesse View Post
    Generating package: Fedora/F9
    Package build failed!
    Package build utility output:
    error: %changelog entries must start with *
    Building target platforms: i386
    Building for target i386
    I get the same error message. I have both the Radeon x1950 Crossfire and Radeon x1950 XTX installed. I have submitted a ticket at the amd customer care site.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •