Page 4 of 22 FirstFirst ... 2345614 ... LastLast
Results 31 to 40 of 216

Thread: AMD Catalyst 8.5 For Linux

  1. #31
    Join Date
    Jan 2008
    Posts
    2

    Default

    Oh well, just got fglrx installed. At first sight there are no improvements: 3d and xv keep tearing, 2d is horribly slow compared to a non-compiz mode. Maybe I'm missing something?

    edit: my kernel is 2.6.24 from ubuntu 8.04, and the graphics is Radeon 9600XT
    Last edited by Lester; 05-22-2008 at 03:04 AM.

  2. #32
    Join Date
    Jul 2007
    Posts
    429

    Default

    Quote Originally Posted by Thetargos View Post
    Hi, I also run F8 on my laptop and I'm intrigued for what exactly do you mean by Warcraft. Do you mean Warcraft III, Warcraft II, World of Warcraft or what Warcraft game?
    World of Warcraft.

    I was about to ask if this driver resolves the issue of forcing Wine to do all 2D DirectX acceleration through OpenGL with the registry key HKCU/Wine/Direct3D/DirectDrawRenderer set to opengl.
    I have never heard of that Wine registry hack before.

  3. #33
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    365

    Default

    ne ideas when fglrx will get around to supporting dri2 so that we can enjoy non-flickering videos with compiz???
    I guess this wont happen until:
    1. Xorg 1.5 is stable
    2. There are enough people out there already using it
    3. DRI1 is considered deprecated
    Which in term will lead to either a driver package thats twice as big as now (dri and dri2 are incompatible to each other) or a dri1 support drop.
    However, Id also like to see support for that one and for kernel mod-setting. What I dont like to think of however is the number of bugs these changes will introduce ;-)

  4. #34
    Join Date
    May 2008
    Posts
    3

    Default can't compile fglrx on 2.6.25

    Hi!

    Anyone using the new driver with the latest 2.6.25.4 kernel? I can't get around compiling the kernel module

  5. #35

    Default

    I am trying to build on Ubuntu Hardy 64-bit but I get this error(I copy the last part):

    dpkg-shlibdeps: warning: symbol XauFileName used by debian/xorg-driver-fglrx/usr/sbin/atieventsd found in none of the libraries.
    dpkg-shlibdeps: warning: debian/xorg-driver-fglrx/usr/sbin/atieventsd shouldn't be linked with libXrender.so.1 (it uses none of its symbols).
    dpkg-shlibdeps: failure: couldn't find library libfglrx_gamma.so.1 needed by debian/xorg-driver-fglrx/usr/bin/fglrx_xgamma (its RPATH is '').
    Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
    To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
    dh_shlibdeps: command returned error code 512
    make: *** [binary] Error 1
    dpkg-buildpackage: failure: debian/rules binary gave error exit status 2
    I am using an x1800xl. What should I do? obviously the hardy scripts are broken. Plz help me because I had the same problem with 8.4.

  6. #36
    Join Date
    Aug 2007
    Posts
    32

    Default

    This has to be the weirdest problem ever;

    sudo ./ati-driver-installer-8-5-x86.x86_64.run --buildpkg Ubuntu/hardy
    Created directory fglrx-install.br4952
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.493............................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. ........
    ==================================================
    ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Ubuntu/hardy
    Resolving build dependencies...
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldn't find package can't
    Unable to resolve can't parse dependency ooobasis30-en_us-res
    can't parse dependency ooobasis30-en_us-help
    can't parse dependency ooobasis30-en_us
    can't parse dependency ooobasis30-en_us-base
    can't parse dependency ooobasis30-en_us-math
    can't parse dependency ooobasis30-en_us-calc
    can't parse dependency ooobasis30-en_us-onlineupd
    can't parse dependency ooobasis30-en_us-impress
    can't parse dependency ooobasis30-en_us-draw
    can't parse dependency ooobasis30-en_us-writer. Please manually install and try again.
    Removing temporary directory: fglrx-install.br4952

  7. #37
    Join Date
    Jan 2008
    Posts
    16

    Default

    There's some nice changes in the new drivers that I've noticed.

    First of all, the glSelect bug that plagued blender (object selection lag) seems to be totally gone, I imagine this would be true for Maya also.

    Another interesting change is in dmesg:

    [fglrx] Adapter chains initialized successfully!
    [fglrx] CF object manager initialized successfully!
    [fglrx] vendor: 1002 device: 9501 count: 1

    It's not exactly difficult to see what this is, albeit it's not official, there might be unofficial support for crossfire now. Strangely the pci-id for 3870 X2 seems to be lacking still tho.

    The new libatiadlxx.so that appeared looks to me like a library for accessing and manipulating ATIFGLEXTENSION.

  8. #38
    Join Date
    May 2008
    Posts
    1

    Default

    8.5 is crap again.
    Kernel modules does compile with 2.6.25 but does not load on amd64:
    Code:
    fglrx: Unknown symbol flush_tlb_page
    A kernel patch is needed:
    Code:
    --- linux-2.6.25/arch/x86/kernel/smp_64.c.orig    2008-04-20 23:29:10.000000000 -0300
    +++ linux-2.6.25/arch/x86/kernel/smp_64.c    2008-04-20 23:29:39.000000000 -0300
    @@ -269,6 +269,7 @@
    
            preempt_enable();
     }
    +EXPORT_UNUSED_SYMBOL(flush_tlb_page);
    
     static void do_flush_tlb_all(void* info)
     {
    Then it loads. But the driver does not work on my X1650Pro - I get only blank screen with white line flickering on the bottom with no error messages in log.

    I hope that radeonhd will get xv acceleration soon.

  9. #39

    Angry ATI quality control!! - fedora buildpkg error

    i'm working with fedora 8 and a HD240PCIE, and today i did download the ati-driver-installer-8-5-x86.x86_64.run
    I did start testing with a classic build package command, but...

    ./ati-driver-installer-8-5-x86.x86_64.run --buildpkg Fedora/F8
    Created directory fglrx-install.u15787
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.493.........
    ==================================================
    ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Fedora/F8
    Package build failed!
    Package build utility output:
    error: %changelog entries must start with *
    Building target platforms: i386
    Building for target i386
    Removing temporary directory: fglrx-install.u15787


    ach! so i did extract the archive with the command:

    ./ati-driver-installer-8-5-x86.x86_64.run --extract exp


    the error was in the file - exp/packages/Fedora/ATI-fglrx.spec-tmpl

    just a wrong comment i said.... Let's start to manually rebuild the package and... BLAM!

    ./ati-installer.sh 8-5 --buildpkg Fedora/F8
    ==================================================
    ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Fedora/F8
    Package build failed!
    Package build utility output:
    Building target platforms: i386
    Building for target i386
    ........... [TWO PAGES OF OUTPUT] ...........
    RPM build errors:
    Installed (but unpackaged) file(s) found:
    /usr/X11R6/lib/libatiadlxx.so


    Well,let me say what i thik this new release... mmmm may be now isnt'a good idea! but i give my best compliments to ATI's developers

    i hope to come back soon with the solution
    bye

  10. #40
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    365

    Default

    I have written a solution to this in the other fglrx 8.493 (I refuse to call it Catalyst ) thread.
    http://www.phoronix.com/forums/showp...2&postcount=44
    I didn't know about the --extract thing, so it's a bit easier for you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •